Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gentoo Local Security Checks >> [GLSA-200411-03] Apache 1.3: Buffer overflow vulnerability in mod_include


Vulnerability Assessment Details

[GLSA-200411-03] Apache 1.3: Buffer overflow vulnerability in mod_include

Vulnerability Assessment Summary
Apache 1.3: Buffer overflow vulnerability in mod_include

Detailed Explanation for this Vulnerability Assessment
The remote host is affected by the vulnerability described in GLSA-200411-03
(Apache 1.3: Buffer overflow vulnerability in mod_include)


A possible buffer overflow exists in the get_tag() function of
mod_include.c.

Impact

If Server Side Includes (SSI) are enabled, a local attacker may be able to
run arbitrary code with the rights of an httpd child process by making use
of a specially-crafted document with malformed SSI.

Workaround

There is no known workaround at this time.

References:
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0940
http://www.apacheweek.com/features/security-13


Solution:
All Apache users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose ">=net-www/apache-1.3.32-r1"


Network Security Threat Level: Medium


Networks Security ID:

Vulnerability Assessment Copyright: (C) 2005 Michel Arboi

Cables, Connectors

T343 Crucial M500 120GB SSD Hard Drive
$30.0
T343   Crucial M500 120GB SSD Hard Drive pictureHP EliteBook 8560W / i5 2.50Ghz / 2GB / No Hard Drive / No Operating System
$166.0
HP EliteBook 8560W / i5 2.50Ghz / 2GB / No Hard Drive  / No Operating System pictureT342 ADATA S510 Series 2.5" 120GB SATA (SSD)
$30.0
T342    ADATA S510 Series 2.5WESTERN DIGITAL WD MY BOOK ESSENTIAL 2TB EXTERNAL HARD DRIVE (WDBACW0020HBK-00)
$49.99
WESTERN DIGITAL WD MY BOOK ESSENTIAL 2TB EXTERNAL HARD DRIVE (WDBACW0020HBK-00) picture


Discussions

No Discussions have been posted on this vulnerability.