Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gentoo Local Security Checks >> [GLSA-200409-20] mpg123: Buffer overflow vulnerability


Vulnerability Assessment Details

[GLSA-200409-20] mpg123: Buffer overflow vulnerability

Vulnerability Assessment Summary
mpg123: Buffer overflow vulnerability

Detailed Explanation for this Vulnerability Assessment
The remote host is affected by the vulnerability described in GLSA-200409-20
(mpg123: Buffer overflow vulnerability)


mpg123 contains a buffer overflow in the code that handles layer2
decoding of media files.

Impact

A possible hacker can possibly exploit this bug with a specially-crafted mp3 or mp2 file
to execute arbitrary code with the permissions of the user running mpg123.

Workaround

There is no known workaround at this time.

References:
http://www.securityfocus.com/archive/1/374433/2004-09-05/2004-09-11/0
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0805


Solution:
All mpg123 users should upgrade to the latest version:
# emerge sync
# emerge -pv ">=media-sound/mpg123-0.59s-r4"
# emerge ">=media-sound/mpg123-0.59s-r4"


Network Security Threat Level: Medium


Networks Security ID:

Vulnerability Assessment Copyright: (C) 2005 Michel Arboi

Cables, Connectors

Cisco Systems Inc Certification (ICSA FIREWALL) March 1998 / March 1999
$139.95
Cisco Systems Inc Certification (ICSA FIREWALL) March 1998 / March 1999 pictureSonicWall TZ 180 SONICWALL TZ 180 APL17-048 WIRED ROUTER NO ADAPTER
$20.0
SonicWall TZ 180   SONICWALL TZ 180  APL17-048 WIRED ROUTER NO ADAPTER pictureCisco - ASA5515-K7 - Cisco ASA 5515-X Firewall Edition - Security appliance -...
$1250.35
Cisco - ASA5515-K7 - Cisco ASA 5515-X Firewall Edition - Security appliance -... pictureNETGEAR FVS318N Prosafe Wireless 802.11 b/g/n 8-Port Gigabit VPN Firewall
$19.99
NETGEAR FVS318N Prosafe Wireless 802.11 b/g/n 8-Port Gigabit VPN Firewall picture


Discussions

No Discussions have been posted on this vulnerability.