Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gentoo Local Security Checks >> [GLSA-200404-17] ipsec-tools and iputils contain a remote DoS vulnerability


Vulnerability Assessment Details

[GLSA-200404-17] ipsec-tools and iputils contain a remote DoS vulnerability

Vulnerability Assessment Summary
ipsec-tools and iputils contain a remote DoS vulnerability

Detailed Explanation for this Vulnerability Assessment
The remote host is affected by the vulnerability described in GLSA-200404-17
(ipsec-tools and iputils contain a remote DoS vulnerability)


When racoon receives an ISAKMP header, it allocates memory based on the
length of the header field. Thus, a possible hacker may be able to cause a Denial
of Services by creating a header that is large enough to consume all
available system resources.

Impact

This vulnerability may permit a possible hacker to remotely cause a Denial of
Service.

Workaround

A workaround is not currently known for this issue. All users are advised
to upgrade to the latest version of the affected package.

References:
http://ipsec-tools.sourceforge.net/
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0403


Solution:
ipsec-tools users should upgrade to version 0.2.5 or later:
# emerge sync
# emerge -pv ">=net-firewall/ipsec-tools-0.3.1"
# emerge ">=net-firewall/ipsec-tools-0.3.1"
iputils users should upgrade to version 021109-r3 or later:
# emerge sync
# emerge -pv ">=net-misc/iputils-021109-r3"
# emerge ">=net-misc/iputils-021109-r3"


Network Security Threat Level: Medium


Networks Security ID:

Vulnerability Assessment Copyright: (C) 2005 Michel Arboi

Cables, Connectors

DELL POWEREDGE R430 SERVER E5-2683V3 2.0GHZ 64GB 4 X 600GB H730
$3759.0
DELL POWEREDGE R430 SERVER E5-2683V3 2.0GHZ 64GB 4 X 600GB H730 pictureDELL POWEREDGE R430 SERVER E5-2660V4 2GHZ 96GB 2 X 300GB H730
$3269.0
DELL POWEREDGE R430 SERVER E5-2660V4 2GHZ 96GB 2 X 300GB H730 pictureDELL POWEREDGE R720 8B 2.5 SERVER E5-2660V2 2.20GHZ 192GB 6 X 480GB SSD H710P
$4459.0
DELL POWEREDGE R720 8B 2.5 SERVER E5-2660V2 2.20GHZ 192GB 6 X 480GB SSD H710P pictureDELL POWEREDGE R720 8B 2.5 SERVER TWO E5-2630LV2 2.40GHZ 64GB 2 X 800GB SSD H310
$2429.0
DELL POWEREDGE R720 8B 2.5 SERVER TWO E5-2630LV2 2.40GHZ 64GB 2 X 800GB SSD H310 picture


Discussions

No Discussions have been posted on this vulnerability.