Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gentoo Local Security Checks >> [GLSA-200404-06] Util-linux login may leak sensitive data


Vulnerability Assessment Details

[GLSA-200404-06] Util-linux login may leak sensitive data

Vulnerability Assessment Summary
Util-linux login may leak sensitive data

Detailed Explanation for this Vulnerability Assessment
The remote host is affected by the vulnerability described in GLSA-200404-06
(Util-linux login may leak sensitive data)


In some situations the login program could leak sensitive data due to an
incorrect usage of a reallocated pointer.
NOTE: Only users who have PAM support disabled on their
systems (i.e. -PAM in their USE variable) will be affected by this
vulnerability. By default, this USE flag is enabled on all
architectures. Users with PAM support on their system receive login binaries
as part of the pam-login package, which remains unaffected.

Impact

A remote attacker may obtain sensitive data.

Workaround

A workaround is not currently known for this issue. All users are advised to upgrade to the latest version of the affected package.

References:
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0080


Solution:
All util-linux users should upgrade to version 2.12 or later:
# emerge sync
# emerge -pv ">=sys-apps/util-linux-2.12"
# emerge ">=sys-apps/util-linux-2.12"


Network Security Threat Level: Low


Networks Security ID:

Vulnerability Assessment Copyright: (C) 2005 Michel Arboi

Cables, Connectors

HP ProLiant BL460c G6 Blade Server Dual Xeon X5550 QC 2.66GHz 128GB
$841.0
HP ProLiant BL460c G6 Blade Server Dual Xeon X5550 QC 2.66GHz 128GB pictureDELL POWEREDGE M620 REF E5-2630LV2 2.40GHZ 64GB 300GB 15K SAS H310
$1669.0
DELL POWEREDGE M620 REF E5-2630LV2 2.40GHZ 64GB 300GB 15K SAS H310 pictureDELL POWEREDGE M620 REF TWO E5-2667 2.90GHZ 16GB 300GB 15K SAS H710P
$1209.0
DELL POWEREDGE M620 REF TWO E5-2667 2.90GHZ 16GB 300GB 15K SAS H710P pictureDELL POWEREDGE M630 TWO E5-2650V3 2.3GHZ 128GB 2 X 1TB SATA S130
$4089.0
DELL POWEREDGE M630 TWO E5-2650V3 2.3GHZ 128GB 2 X 1TB SATA S130 picture


Discussions

No Discussions have been posted on this vulnerability.