Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gentoo Local Security Checks >> [GLSA-200403-04] Multiple security vulnerabilities in Apache 2


Vulnerability Assessment Details

[GLSA-200403-04] Multiple security vulnerabilities in Apache 2

Vulnerability Assessment Summary
Multiple security vulnerabilities in Apache 2

Detailed Explanation for this Vulnerability Assessment
The remote host is affected by the vulnerability described in GLSA-200403-04
(Multiple security vulnerabilities in Apache 2)


Three vulnerabilities were found:
A memory leak in ssl_engine_io.c for mod_ssl in Apache 2.0.48 and below
permits remote attackers to cause a denial of service attack
via plain HTTP requests to the SSL port of an SSL-enabled server.
Apache fails to filter terminal escape sequences from error
logs that begin with the ASCII (0x1B) sequence and are followed by a
series of arguments. If a remote attacker could inject escape sequences
into an Apache error log, the attacker could take advantages of
weaknesses in various terminal emulators, launching attacks
against remote users including further denial of service attacks,
file modification, and the execution of arbitrary commands.
The Apache mod_disk_cache has been found to be
vulnerable to a weakness that permits attackers to gain access
to authentication credentials through the issue of caching
HTTP hop-by-hop headers which would contain plaintext user
passwords. There is no available resolution for this issue yet.

Impact

No special rights are required for these vulnerabilities. As a result,
all users are recommended to upgrade their Apache installations.

Workaround

There is no immediate workaround
a software upgrade is required.
There is no workaround for the mod_disk_cache issue
users are
recommended to disable the feature on their servers until a patched
version is released.

References:
http://www.securityfocus.com/bid/9933/info/
http://www.apache.org/dist/httpd/Announcement2.html


Solution:
Users are urged to upgrade to Apache 2.0.49:
# emerge sync
# emerge -pv ">=net-www/apache-2.0.49"
# emerge ">=net-www/apache-2.0.49"
# ** IMPORTANT **
# If you are migrating from Apache 2.0.48-r1 or earlier versions,
# it is important that the following directories are removed.
# The following commands should cause no data loss since these
# are symbolic links.
# rm /etc/apache2/lib /etc/apache2/logs /etc/apache2/modules
# rm /etc/apache2/extramodules
# ** ** ** ** **
# ** ALSO NOTE **
# Users who use mod_disk_cache should edit their Apache
# configuration and disable mod_disk_cache.


Network Security Threat Level: Medium


Networks Security ID:

Vulnerability Assessment Copyright: (C) 2005 Michel Arboi

Cables, Connectors

Vtg Power Mac 7200 User Manual and System Disc
$14.5
Vtg Power Mac 7200 User Manual and System Disc pictureMagnetic Power Conector For Vintage Mac Book Pro 2009 (Spare Parts)
$12.99
Magnetic Power Conector For Vintage Mac Book Pro 2009 (Spare Parts) pictureVintage LOT Math Algebra Geometry Trigonometry Computer CD-ROM Software WIN/MAC
$21.98
Vintage LOT Math Algebra Geometry Trigonometry Computer CD-ROM Software WIN/MAC pictureVintage Macintosh Laptop Bag Briefcase w Embroidered Mac Rainbow Apple Logo
$150.0
Vintage Macintosh Laptop Bag Briefcase w Embroidered Mac Rainbow Apple Logo picture


Discussions

No Discussions have been posted on this vulnerability.