Vulnerability Assessment & Network Security Forums
If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important. If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.
Vulnerability Assessment Details
Multiple security vulnerabilities in Apache 2
Detailed Explanation for this Vulnerability Assessment
The remote host is affected by the vulnerability described in GLSA-200403-04
(Multiple security vulnerabilities in Apache 2)
Three vulnerabilities were found:
A memory leak in ssl_engine_io.c for mod_ssl in Apache 2.0.48 and below
permits remote attackers to cause a denial of service attack
via plain HTTP requests to the SSL port of an SSL-enabled server.
Apache fails to filter terminal escape sequences from error
logs that begin with the ASCII (0x1B) sequence and are followed by a
series of arguments. If a remote attacker could inject escape sequences
into an Apache error log, the attacker could take advantages of
weaknesses in various terminal emulators, launching attacks
against remote users including further denial of service attacks,
file modification, and the execution of arbitrary commands.
The Apache mod_disk_cache has been found to be
vulnerable to a weakness that permits attackers to gain access
to authentication credentials through the issue of caching
HTTP hop-by-hop headers which would contain plaintext user
passwords. There is no available resolution for this issue yet.
No special rights are required for these vulnerabilities. As a result,
all users are recommended to upgrade their Apache installations.
There is no immediate workaround
a software upgrade is required.
There is no workaround for the mod_disk_cache issue
recommended to disable the feature on their servers until a patched
version is released.
Users are urged to upgrade to Apache 2.0.49:
# emerge sync
# emerge -pv ">=net-www/apache-2.0.49"
# emerge ">=net-www/apache-2.0.49"
# ** IMPORTANT **
# If you are migrating from Apache 2.0.48-r1 or earlier versions,
# it is important that the following directories are removed.
# The following commands should cause no data loss since these
# are symbolic links.
# rm /etc/apache2/lib /etc/apache2/logs /etc/apache2/modules
# rm /etc/apache2/extramodules
# ** ** ** ** **
# ** ALSO NOTE **
# Users who use mod_disk_cache should edit their Apache
# configuration and disable mod_disk_cache.
Network Security Threat Level: Medium
Networks Security ID:
Vulnerability Assessment Copyright: (C) 2005 Michel Arboi
|Lot of 6 Dell 750W Power Supplies JU081 NPS-750P-S0 for PowerEdge 2950 Server
|Dell H7829 H7970 4U Rapid Rails for PowerEdge 6850 6950 Servers
|Dell Powervault 124T server back up system for Poweredge
|Dell PowerEdge R610 2x X5650 2.66GHz 6 Core 96GB 6x 512GB SATA SSD PERC 6/i
No Discussions have been posted on this vulnerability.