Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gentoo Local Security Checks >> [GLSA-200401-04] GAIM 0.75 Remote overflows


Vulnerability Assessment Details

[GLSA-200401-04] GAIM 0.75 Remote overflows

Vulnerability Assessment Summary
GAIM 0.75 Remote overflows

Detailed Explanation for this Vulnerability Assessment
The remote host is affected by the vulnerability described in GLSA-200401-04
(GAIM 0.75 Remote overflows)


Yahoo changed the authentication methods to their IM servers,
rendering GAIM useless. The GAIM team released a rushed release
solving this issue, however, at the same time a code audit
revealed 12 new vulnerabilities.

Impact

Due to the nature of instant messaging many of these bugs require
man-in-the-middle attacks between the client and the server. But
the underlying protocols are easy to implement and attacking
ordinary TCP sessions is a fairly simple task. As a result, all
users are advised to upgrade their GAIM installation.
Users of GAIM 0.74 or below are affected by 7 of the
vulnerabilities and are encouraged to upgrade.
Users of GAIM 0.75 are affected by 11 of the vulnerabilities
and are encouraged to upgrade to the patched version of GAIM
offered by Gentoo.
Users of GAIM 0.75-r6 are only affected by
4 of the vulnerabilities, but are still urged to upgrade to
maintain security.

Workaround

There is no immediate workaround
a software upgrade is required.

References:
http://www.securityfocus.com/archive/1/351235/2004-01-23/2004-01-29/0


Solution:
All users are recommended to upgrade GAIM to 0.75-r7.
$> emerge sync
$> emerge -pv ">=net-im/gaim-0.75-r7"
$> emerge ">=net-im/gaim-0.75-r7"


Network Security Threat Level: Medium


Networks Security ID:

Vulnerability Assessment Copyright: (C) 2005 Michel Arboi

Cables, Connectors

Dell PowerEdge R610 2x X5650 2.66GHz 6 Core 48GB 6x 300GB 15K SAS PERC H700
$1356.0
Dell PowerEdge R610 2x X5650 2.66GHz 6 Core 48GB 6x 300GB 15K SAS PERC H700 pictureDell PowerEdge R620 2x E5-2680v2 2.8GHz 10 Core 16GB 8x 600GB 10K SAS PERC H710
$3725.0
Dell PowerEdge R620 2x E5-2680v2 2.8GHz 10 Core 16GB 8x 600GB 10K SAS PERC H710 pictureDell PowerEdge R620 2x E5-2670v2 2.5GHz 10 Core 32GB 8x 600GB 10K SAS PERC H710
$3525.0
Dell PowerEdge R620 2x E5-2670v2 2.5GHz 10 Core 32GB 8x 600GB 10K SAS PERC H710 pictureDell PowerEdge R710 2x X5550 2.66GHz Quad Core 32GB 6x 2TB 7.2K SAS PERC H700
$890.0
Dell PowerEdge R710 2x X5550 2.66GHz Quad Core 32GB 6x 2TB 7.2K SAS PERC H700 picture


Discussions

No Discussions have been posted on this vulnerability.