Vulnerability Assessment & Network Security Forums
If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important. If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.
Vulnerability Assessment Details
Apache mod_python Denial of Service vulnerability
Detailed Explanation for this Vulnerability Assessment
The remote host is affected by the vulnerability described in GLSA-200401-03
(Apache mod_python Denial of Service vulnerability)
The Apache Foundation has reported that mod_python may be prone to
Denial of Service attacks when handling a malformed
query. Mod_python 2.7.9 was released to fix the vulnerability,
however, because the vulnerability has not been fully fixed,
version 2.7.10 has been released.
Users of mod_python 3.0.4 are not affected by this vulnerability.
Although there are no known public exploits known for this
exploit, users are recommended to upgrade mod_python to ensure the
security of their infrastructure.
Mod_python 2.7.10 has been released to solve this issue
no immediate workaround.
All users using mod_python 2.7.9 or below are recommended to
update their mod_python installation:
$> emerge sync
$> emerge -pv ">=dev-python/mod_python-2.7.10"
$> emerge ">=dev-python/mod_python-2.7.10"
$> /etc/init.d/apache restart
Network Security Threat Level: Low
Networks Security ID:
Vulnerability Assessment Copyright: (C) 2005 Michel Arboi
|Asus GeForce GTX580 water cooled video card 2-DVI, 1 Mini HDMI w/ cpu cooler
|SR0P4 Xeon E3-1230V2 3.3GHz Quad-Core 8M Processor LGA1155 CPU E3-1230 V2
|Intel Core i7-3820 3.6GHz 10MB 5GT/s LGA2011 SR0LD CPU Processor
|Intel Core i3-3240 (SR0RH) @ 3.40GHz / 3MB / Socket 1155 / Ivy Bridge Processor
No Discussions have been posted on this vulnerability.