Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gentoo Local Security Checks >> [GLSA-200401-03] Apache mod_python Denial of Service vulnerability


Vulnerability Assessment Details

[GLSA-200401-03] Apache mod_python Denial of Service vulnerability

Vulnerability Assessment Summary
Apache mod_python Denial of Service vulnerability

Detailed Explanation for this Vulnerability Assessment
The remote host is affected by the vulnerability described in GLSA-200401-03
(Apache mod_python Denial of Service vulnerability)


The Apache Foundation has reported that mod_python may be prone to
Denial of Service attacks when handling a malformed
query. Mod_python 2.7.9 was released to fix the vulnerability,
however, because the vulnerability has not been fully fixed,
version 2.7.10 has been released.
Users of mod_python 3.0.4 are not affected by this vulnerability.

Impact

Although there are no known public exploits known for this
exploit, users are recommended to upgrade mod_python to ensure the
security of their infrastructure.

Workaround

Mod_python 2.7.10 has been released to solve this issue
there is
no immediate workaround.

References:
http://www.modpython.org/pipermail/mod_python/2004-January/014879.html


Solution:
All users using mod_python 2.7.9 or below are recommended to
update their mod_python installation:
$> emerge sync
$> emerge -pv ">=dev-python/mod_python-2.7.10"
$> emerge ">=dev-python/mod_python-2.7.10"
$> /etc/init.d/apache restart


Network Security Threat Level: Low


Networks Security ID:

Vulnerability Assessment Copyright: (C) 2005 Michel Arboi

Cables, Connectors

Thermaltake Muse R‑Duo RAID N0006USU
$65.0
Thermaltake Muse R‑Duo RAID N0006USU pictureHP DL360 G7 64bit VT Server 2x Hexa-Core 3.06GHz / 96GB Ram / 4x 300GB SAS RAID5
$809.0
HP DL360 G7 64bit VT Server 2x Hexa-Core 3.06GHz / 96GB Ram / 4x 300GB SAS RAID5 pictureHP DL360 G7 64-bit VT Server 2x Hexa-Core 3.46GHz / 24GB / 4x 72GB 15K SAS RAID5
$979.0
HP DL360 G7 64-bit VT Server 2x Hexa-Core 3.46GHz / 24GB / 4x 72GB 15K SAS RAID5 pictureDell Precision T3600 Xeon QC E5-1603 2.8GHz 32GB 2x 250GB Quadro 2000 H310 Raid*
$329.27
Dell Precision T3600 Xeon QC E5-1603 2.8GHz 32GB 2x 250GB Quadro 2000 H310 Raid* picture


Discussions

No Discussions have been posted on this vulnerability.