Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> FlatNuke < 2.5.6 Multiple Vulnerabilities


Vulnerability Assessment Details

FlatNuke < 2.5.6 Multiple Vulnerabilities

Vulnerability Assessment Summary
Checks for multiple vulnerabilities in FlatNuke < 2.5.6

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains a PHP application that is affected by
multiple vulnerabilities.

Description :

The remote host is running FlatNuke, a content management system
written in PHP and using flat files rather than a database for its
storage.

The version of FlatNuke installed on the remote host suffers from
several flaws:

- Arbitrary PHP Code Execution Vulnerability
The application fails to remove newlines from a user's
registration information and stores it as a PHP file with
a known path. A possible hacker can leverage this flaw to
execute arbitrary PHP code on the remote host subject to
the rights of the web server userid.

- Multiple Cross-Site Scripting Vulnerabilities
Various scripts do not sanitize user-supplied input
through several parameters before using it in dynamically
generated pages, which can be exploited by attackers to
launch cross-site scripting attacks against the affected
application.

See also :

http://retrogod.altervista.org/flatnuke.html

Solution :

Upgrade to FlatNuke 2.5.6 or later.

Network Security Threat Level:

High / CVSS Base Score : 7
(AV:R/AC:L/Au:NR/C:P/A:P/I:P/B:N)

Networks Security ID: 14483, 14485

Vulnerability Assessment Copyright: This script is Copyright (C) 2005-2006 Tenable Network Security

Cables, Connectors

Dell PowerEdge R620 Server Dual E5-2667 v2 8 Core 3.3GHz 64GB 8x 600GB SAS 8 Bay
$4039.0
Dell PowerEdge R620 Server Dual E5-2667 v2 8 Core 3.3GHz 64GB 8x 600GB SAS 8 Bay pictureDell PowerEdge R710 Server Dual Xeon X5650 6C 2.66GHz 288GB 6x 1TB, 2x 800GB SSD
$2889.0
Dell PowerEdge R710 Server Dual Xeon X5650 6C 2.66GHz 288GB 6x 1TB, 2x 800GB SSD pictureDell PowerEdge R610 2x X5690 3.46GHz 6 Core 48GB 6x 300GB 10K SAS PERC H700
$1399.0
Dell PowerEdge R610 2x X5690 3.46GHz 6 Core 48GB 6x 300GB 10K SAS PERC H700 pictureDell PowerEdge R710 Server Dual X5650 6C 2.66GHz 144GB 4x 900GB SAS 2.5in RPS
$1531.0
Dell PowerEdge R710 Server Dual X5650 6C 2.66GHz 144GB 4x 900GB SAS 2.5in RPS picture


Discussions

No Discussions have been posted on this vulnerability.