Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Fedora Local Security Checks >> Fedora Core 5 2006-1049: python


Vulnerability Assessment Details

Fedora Core 5 2006-1049: python

Vulnerability Assessment Summary
Check for the version of the python package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory FEDORA-2006-1049 (python).

Python is an interpreted, interactive, object-oriented programming
language often compared to Tcl, Perl, Scheme or Java. Python includes
modules, classes, exceptions, very high level dynamic data types and
dynamic typing. Python supports interfaces to many system calls and
libraries, as well as to various windowing systems (X11, Motif, Tk,
Mac and MFC).

Programmers can write new built-in modules for Python in C or C++.
Python can be used as an extension language for applications that need
a programmable interface. This package contains most of the standard
Python modules, as well as modules for interfacing to the Tix widget
set for Tk and RPM.

Note that documentation for Python is provided in the python-docs
package.

Update Information:

Fix overflow bug in unicode repr


Solution : Get the newest Fedora Updates
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2007 Tenable Network Security

Cables, Connectors

INTEL RMS25CB040 INTEGRATED RAID MODULE
$374.81
INTEL RMS25CB040  INTEGRATED RAID MODULE pictureNEW. DELL 0M778G SAS 5/E RAID CONTROLLER PCI-E
$25.0
NEW. DELL 0M778G SAS 5/E RAID CONTROLLER PCI-E picture512MB Cache Ram Upgrade for DELL PERC 5i RAID Card TU005 WX072 FY387 GT281
$4.5
512MB Cache Ram Upgrade for DELL PERC 5i  RAID Card TU005 WX072 FY387 GT281 pictureIBM 25R8071 LSI SAS3444E 3Gb PCI-E RAID Controller Card---Tested OK
$11.5
IBM 25R8071 LSI SAS3444E 3Gb PCI-E RAID Controller Card---Tested OK picture


Discussions

No Discussions have been posted on this vulnerability.