Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Fedora Local Security Checks >> Fedora Core 4 2005-1093: openswan


Vulnerability Assessment Details

Fedora Core 4 2005-1093: openswan

Vulnerability Assessment Summary
Check for the version of the openswan package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory FEDORA-2005-1093 (openswan).


Openswan is a free implementation of IPSEC & IKE for Linux. IPSEC is
the Internet Protocol Security and uses strong cryptography to provide
both authentication and encryption services. These services permit you
to build secure tunnels through untrusted networks. Everything passing
through the untrusted net is encrypted by the ipsec gateway machine and
decrypted by the gateway at the other end of the tunnel. The resulting
tunnel is a virtual private network or VPN.

This package contains the daemons and userland tools for setting up
Openswan on a freeswan enabled kernel.

Update Information:

NISCC has reported two Denial of Service issues in Openswan.
The first involves a specially crafted 3DES packet with an
invalid key length.

The Openswan project has relased version 2.4.4 to fix both
issues.

See [8]http://www.openswan.org/ for details.


Solution : Get the newest Fedora Updates
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2005 Tenable Network Security

Cables, Connectors

DELL POWEREDGE R530 SERVER TWO E5-2603V3 1.6GHZ 384GB 500GB SATA H730
$6929.0
DELL POWEREDGE R530 SERVER TWO E5-2603V3 1.6GHZ 384GB 500GB SATA H730 pictureDELL POWEREDGE C6320 4 NODE 8 X E5-2603V4 1.7GHZ 16 X 32GB 2133MHZ LRDIMM 5 X 25
$11529.0
DELL POWEREDGE C6320 4 NODE 8 X E5-2603V4 1.7GHZ 16 X 32GB 2133MHZ LRDIMM 5 X 25 pictureDELL POWEREDGE R900 8B SERVER FOUR INTEL L7345 16GB 5 X 600GB 15K SAS
$2199.0
DELL POWEREDGE R900 8B SERVER FOUR INTEL L7345 16GB 5 X 600GB 15K SAS pictureDELL POWEREDGE R710 X5675 3.06GHZ 128GB 3 X 300GB 10K SAS H700 512MB
$1739.0
DELL POWEREDGE R710 X5675 3.06GHZ 128GB 3 X 300GB 10K SAS H700 512MB picture


Discussions

No Discussions have been posted on this vulnerability.