Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Fedora Local Security Checks >> Fedora Core 3 2005-474: ruby


Vulnerability Assessment Details

Fedora Core 3 2005-474: ruby

Vulnerability Assessment Summary
Check for the version of the ruby package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory FEDORA-2005-474 (ruby).

Ruby is the interpreted scripting language for quick and easy
object-oriented programming. It has many features to process text
files and to do system management tasks (as in Perl). It is simple,
straight-forward, and extensible.


* Wed Jun 22 2005 Akira TAGOH - 1.8.2-1.fc3.3

- ruby-1.8.2-xmlrpc-CVE-2005-1992.patch: fixed the arbitrary command
execution
on XMLRPC server. (#161096)



Solution : http://www.fedoranews.org/blog/index.php?p=726
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2005 Tenable Network Security

Cables, Connectors

Lot of 2 Intel Xeon E5-2407 V2 2.40GHz 10MB QC 80W LGA1365 SR1AK
$24.0
Lot of 2 Intel Xeon E5-2407 V2 2.40GHz 10MB QC 80W LGA1365 SR1AK pictureLenovo ThinkPad P71 17.3" Laptop Intel Xeon 3 Ghz 63.9990234375 GB Ram 1024 GB
$3366.72
Lenovo ThinkPad P71 17.3HP ProLiant DL360 Gen9 8SFF CTO Server 2x E5-2620v3 2.4GHz - 32GB - 8x 1TB 7.2k
$993.04
HP ProLiant DL360 Gen9 8SFF CTO Server 2x E5-2620v3 2.4GHz - 32GB - 8x 1TB 7.2k pictureLot of 6 Intel Xeon E5506 SLBF8 Costa Rica Quad Core 2.13GHz/4MB/4.8
$19.77
Lot of 6 Intel Xeon E5506 SLBF8 Costa Rica Quad Core 2.13GHz/4MB/4.8  picture


Discussions

No Discussions have been posted on this vulnerability.