Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Fedora Local Security Checks >> Fedora Core 3 2005-1145: perl


Vulnerability Assessment Details

Fedora Core 3 2005-1145: perl

Vulnerability Assessment Summary
Check for the version of the perl package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory FEDORA-2005-1145 (perl).

Perl is a high-level programming language with roots in C, sed, awk
and shell scripting. Perl is good at handling processes and files,
and is especially good at handling text. Perl's hallmarks are
practicality and efficiency. While it is used to do a lot of
different things, Perl's most common applications are system
administration utilities and web programming. A large proportion of
the CGI scripts on the web are written in Perl. You need the perl
package installed on your system so that your system can handle Perl
scripts.

Install this package if you want to program in Perl or enable your
system to handle Perl scripts.

Update Information:

o Updated upstream fix for sprintf integer overflow
vulnerabilities CVE-2005-3962 and CVE-2005-3912,
including new Sys::Syslog 0.08

o Updated fix fo bug 136009 / MakeMaker LD_RUN_PATH issue:
restore previous default Red Hat behavior of removing the
MakeMaker generated LD_RUN_PATH setting from the link
command . Document this removal, as it contravenes upstream
default behavior, and provide a USE_MM_LD_RUN_PATH
MakeMaker member to enable use of the MakeMaker generated
LD_RUN_PATH .


Solution : Get the newest Fedora Updates
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2005 Tenable Network Security

Cables, Connectors

5015B Micro Server XIV
$95.0
5015B Micro Server XIV pictureHP PROLIANT MICROSERVER G8 E3-1220LV2 2.3GHZ 4GB 3 X 1TB MIDLINE
$1049.0
HP PROLIANT MICROSERVER G8 E3-1220LV2 2.3GHZ 4GB 3 X 1TB MIDLINE pictureHP PROLIANT MICROSERVER G8 CORE I3-3240 3.4GHZ 8GB 3 X 1TB MIDLINE
$1039.0
HP PROLIANT MICROSERVER G8 CORE I3-3240 3.4GHZ 8GB 3 X 1TB MIDLINE pictureHP PROLIANT MICROSERVER G8 CORE I3-3240 3.4GHZ 8GB 4 X 1TB MIDLINE
$1189.0
HP PROLIANT MICROSERVER G8 CORE I3-3240 3.4GHZ 8GB 4 X 1TB MIDLINE picture


Discussions

No Discussions have been posted on this vulnerability.