Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Fedora Local Security Checks >> Fedora Core 2 2004-264: ruby


Vulnerability Assessment Details

Fedora Core 2 2004-264: ruby

Vulnerability Assessment Summary
Check for the version of the ruby package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory FEDORA-2004-264 (ruby).

Ruby is the interpreted scripting language for quick and easy
object-oriented programming. It has many features to process text
files and to do system management tasks (as in Perl). It is simple,
straight-forward, and extensible.


* Thu Aug 19 2004 Akira TAGOH 1.8.1-6

- security fix [CVE-2004-0755]
- ruby-1.8.1-cgi_session_perms.patch: sets the permission of the session data
file to 0600. (#130063)



Solution : http://www.fedoranews.org/updates/FEDORA-2004-264.shtml
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

LENOVO Thinkpad T430 Intel Core i5-3320M @ 2.60GHz 4GB LAPTOP ADMIN LOCKED BIOS
$29.99
LENOVO Thinkpad T430 Intel Core i5-3320M @ 2.60GHz 4GB LAPTOP ADMIN LOCKED BIOS pictureLENOVO T440 TOUCHSCREEN 8GB RAM 480GB SSD & 2TB HDD FINGERPRINT HD+ SCREEN
$625.0
LENOVO T440 TOUCHSCREEN 8GB RAM 480GB SSD & 2TB HDD FINGERPRINT HD+ SCREEN pictureLenovo IdeaPad 300-15ISK 15.6" i7-6500U 2.50GHz 8GB 1TB HDD Windows 10 Laptop
$0.99
Lenovo IdeaPad 300-15ISK 15.6Lenovo Yoga 730-15IKB Touch-Scr 15.6" i7-8550u Quad 16GB 512GB SSD 4GB GTX 1050
$1059.35
Lenovo Yoga 730-15IKB Touch-Scr 15.6


Discussions

No Discussions have been posted on this vulnerability.