Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Fedora Local Security Checks >> Fedora Core 1 2003-034: lftp


Vulnerability Assessment Details

Fedora Core 1 2003-034: lftp

Vulnerability Assessment Summary
Check for the version of the lftp package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory FEDORA-2003-034 (lftp).

LFTP is a sophisticated ftp/http file transfer program. Like bash, it
has job control and uses the readline library for input. It has
bookmarks, built-in mirroring, and can transfer several files in
parallel. It is designed with reliability in mind.


Update Information:

Ulf Härnhammar found a remotely-triggerable buffer overflow in lftp.

A possible hacker could create a carefully crafted directory on a website
such that, if a user connects to that directory using the lftp client
and subsequently issues a 'ls' or 'rels' command, the attacker could
execute arbitrary code on the users machine. The Common
Vulnerabilities and Exposures project (cve.mitre.org) has assigned
the name CVE-2003-0963 to this issue.

Users of lftp are advised to upgrade to these erratum packages, which
upgrade lftp to a version which is not vulnerable to this issue.

Red Hat would like to thank Ulf Härnhammar for discovering and
alerting us to this issue.



Solution : http://www.fedoranews.org/updates/FEDORA-2003-034.shtml
Network Security Threat Level: High

Networks Security ID: 9210

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

Dell R730 Dual E5-2660 v3 10C 2.6GHz 512GB 4x 480GB SSD H730 iDRAC 2.5in Rails
$10087.0
Dell R730 Dual E5-2660 v3 10C 2.6GHz 512GB 4x 480GB SSD H730 iDRAC 2.5in Rails pictureHP Renew DL360 G9 Single E5-2620 v3 6C 2.4GHz 128GB 8x 450GB SAS P440ar Rails
$4492.0
HP Renew DL360 G9 Single E5-2620 v3 6C 2.4GHz 128GB 8x 450GB SAS P440ar Rails pictureDell R720xd OEM Dual E5-2660 8C 2.2GHz 384GB 12x 1TB SAS 12 Bay 3.5in Rails RPS
$3606.0
Dell R720xd OEM Dual E5-2660 8C 2.2GHz 384GB 12x 1TB SAS 12 Bay 3.5in Rails RPS pictureDell R710 Dual L5520 QC 2.26GHz 192GB 2x 300GB 6G, 6x 600GB 6G H700 iDRAC Rails
$1676.0
Dell R710 Dual L5520 QC 2.26GHz 192GB 2x 300GB 6G, 6x 600GB 6G H700 iDRAC Rails picture


Discussions

No Discussions have been posted on this vulnerability.