Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gain root remotely >> FTGate <= 4.4.002 Multiple Vulnerabilities


Vulnerability Assessment Details

FTGate <= 4.4.002 Multiple Vulnerabilities

Vulnerability Assessment Summary
Checks for multiple vulnerabilities in FTGate <= 4.4.002

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote mail server is affected by multiple flaws.

Description :

The remote host appears to be running a version of FTGate, a
commercial groupware mail server for Windows from FTGate Technology
Ltd.

The web server used to administer FTGate on the remote host fails to
sanitize input to the 'href' parameter of the 'index.fts' script
before using it to generate dynamic content. An unauthenticated
attacker can leverage this flaw to inject arbitrary HTML and script
code into a user's browser, to be evaluated within the security
context of the affected application.

In addition, there reportedly is a buffer overflow vulnerability in
the web server as well as several format string vulnerabilities in the
accompanying IMAP and POP3 services. An unauthenticated attacker may
be able to exploit these issues to execute code on the affected host.

See also :

http://lists.grok.org.uk/pipermail/full-disclosure/2005-December/040390.html
http://lists.grok.org.uk/pipermail/full-disclosure/2005-December/040391.html
http://lists.grok.org.uk/pipermail/full-disclosure/2005-December/040392.html
http://lists.grok.org.uk/pipermail/full-disclosure/2005-December/040393.html

Solution :

Upgrade to FTGate version 4.4.004 or later as it reportedly fixes
these issues.

Network Security Threat Level:

High / CVSS Base Score : 7.0
(AV:R/AC:L/Au:NR/C:P/I:P/A:P/B:N)

Networks Security ID: 15972

Vulnerability Assessment Copyright: This script is Copyright (C) 2005-2006 Tenable Network Security

Cables, Connectors

Panasonic KX-UTG 300B VOIP SIP Phone
$90.0
Panasonic KX-UTG 300B VOIP SIP Phone pictureMagicJack Original Model A921 VoIP Phone Adapter W/ USB Extension Cord NEW
$10.85
MagicJack Original Model A921 VoIP Phone Adapter W/ USB Extension Cord NEW  pictureGrandstream GPX2000 VoIP Business Phone with all cables NEW Never Used
$39.95
Grandstream GPX2000 VoIP Business Phone with  all cables NEW Never Used pictureOoma Telo | Home Phone Service | VoIP
$35.0
Ooma Telo | Home Phone Service | VoIP picture


Discussions

No Discussions have been posted on this vulnerability.