Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> Drupal Comment Preview Code Execution Vulnerability (2)


Vulnerability Assessment Details

Drupal Comment Preview Code Execution Vulnerability (2)

Vulnerability Assessment Summary
Tries to execute a command via Drupal

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains a PHP application that permits execution
of arbitrary code.

Description :

The version of Drupal installed on the remote host fails to properly
validate previews on comments and permits access to more than one input
filter, which is not true by default. A possible hacker can leverage this
issue while previewing a comment to have it interpreted as PHP code,
which will result in it being executed on the affected host with the
rights of the web server user id.

See also :

http://drupal.org/node/113935

Solution :

Upgrade to Drupal version 4.7.6 / 5.1 or later.

Network Security Threat Level:

Medium / CVSS Base Score : 6
(AV:R/AC:H/Au:NR/C:P/A:P/I:P/B:N)

Networks Security ID: 22306

Vulnerability Assessment Copyright: This script is Copyright (C) 2007 Tenable Network Security

Cables, Connectors

IBM HS22V BLADECENTER SERVER E5640 2.66GHZ 8GB RAM NO HDD
$519.0
IBM HS22V BLADECENTER SERVER E5640 2.66GHZ 8GB RAM NO HDD picture


Discussions

No Discussions have been posted on this vulnerability.