Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> Drupal Arbitrary PHP Code Execution Vulnerability


Vulnerability Assessment Details

Drupal Arbitrary PHP Code Execution Vulnerability

Vulnerability Assessment Summary
Checks version of Drupal

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains a PHP application that is prone to
arbitrary PHP code injection.

Description :

The version of Drupal installed on the remote host, according to its
version number, permits attackers to embed arbitrary PHP code when
submitting a comment or posting. Note that successful exploitation
requires that public comments or postings be permited in Drupal.

See also :

http://marc.theaimsgroup.com/?l=bugtraq&m=112015287827452&w=2
http://drupal.org/drupal-4.6.2

Solution :

Upgrade to Drupal version 4.5.4 / 4.6.2 or later.

Network Security Threat Level:

Medium / CVSS Base Score : 6
(AV:R/AC:H/Au:NR/C:P/A:P/I:P/B:N)

Networks Security ID: 14110

Vulnerability Assessment Copyright: This script is Copyright (C) 2005-2006 Tenable Network Security

Cables, Connectors

Samsung PM851 Series 128GB SSD Fresh Pull 2.5" 7mm 6Gb/s SATA III
$38.0
Samsung PM851 Series 128GB SSD Fresh Pull 2.5ALIENWARE AURORA HARD DRIVE CAGE WITH CADDY
$49.95
ALIENWARE AURORA HARD DRIVE CAGE WITH CADDY pictureHitachi 640GB 5400RPM 2.5" HDD Hard Drive HTS547564A9E384 0J15342 DA3931 jjj121
$25.99
Hitachi 640GB 5400RPM 2.5SONY VAIO VPCF2 SERIES VPCF226FM HDD Hard Drive Caddy W/ Screws
$10.99
SONY VAIO VPCF2 SERIES VPCF226FM HDD Hard Drive Caddy W/ Screws picture


Discussions

No Discussions have been posted on this vulnerability.