Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> Dokeos extAuthSource Parameter Array Remote File Include Vulnerability


Vulnerability Assessment Details

Dokeos extAuthSource Parameter Array Remote File Include Vulnerability

Vulnerability Assessment Summary
Tries to read a local file with Dokeos

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains a PHP script that is affected by a
remote file inclusion attack.

Description :

The remote host is running Dokeos, an open-source, e-learning and
course management web application written in PHP.

The version of Dokeos installed on the remote host fails to sanitize
input to the 'extAuthSource' parameter array before using it to
include PHP code in the 'claroline/inc/claro_init_local.inc.php'
script. Provided PHP's 'register_globals' setting is enabled, an
unauthenticated attacker may be able to exploit this issue to view
arbitrary files on the remote host or to execute arbitrary PHP code,
possibly taken from third-party hosts.

Note that, while the vulnerability exists in Claroline itself, Dokeos
is affected as well because it includes a vulnerable version of
Claroline.

See also :

http://www.gulftech.org/?node=research&article_id=00112-09142006

Solution :

Unknown at this time.

Network Security Threat Level:

Medium / CVSS Base Score : 6
(AV:R/AC:H/Au:NR/C:P/A:P/I:P/B:N)

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2006 Tenable Network Security

Cables, Connectors

IBM HS23E BLADECENTER SERVER TWO E5-2450L 1.80GHZ 32GB 2 X 300GB 10K SAS
$1649.0
IBM HS23E BLADECENTER SERVER TWO E5-2450L 1.80GHZ 32GB 2 X 300GB 10K SAS pictureHP PROLIANT BL460C G8 SERVER E5-2695V2 2.40GHZ 48GB 2 X 300GB 15K SAS
$2229.0
HP PROLIANT BL460C G8 SERVER E5-2695V2 2.40GHZ 48GB 2 X 300GB 15K SAS pictureDELL POWEREDGE M710 SERVER X5650 2.66GHZ 48GB 2 X 300GB 15K SAS SAS 6/IR
$1049.0
DELL POWEREDGE M710 SERVER X5650 2.66GHZ 48GB 2 X 300GB 15K SAS SAS 6/IR pictureDELL POWEREDGE M620 BLADE TWO E5-2603 1.80GHZ 32GB 2 X 1.8TB 10K SAS H310
$1559.0
DELL POWEREDGE M620 BLADE TWO E5-2603 1.80GHZ 32GB 2 X 1.8TB 10K SAS H310 picture


Discussions

No Discussions have been posted on this vulnerability.