Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA957] DSA-957-2 imagemagick


Vulnerability Assessment Details

[DSA957] DSA-957-2 imagemagick

Vulnerability Assessment Summary
DSA-957-2 imagemagick

Detailed Explanation for this Vulnerability Assessment

Florian Weimer discovered that delegate code in ImageMagick is
vulnerable to shell command injection using specially crafted file
names. This permits attackers to encode commands inside of graphic
commands. With some user interaction, this is exploitable through
Gnus and Thunderbird. This update filters out the '$' character as
well, which was forgotten in the former update.
For the old stable distribution (woody) this problem has been fixed in
version 5.4.4.5-1woody8.
For the stable distribution (sarge) this problem has been fixed in
version 6.0.6.2-2.6.
For the unstable distribution (sid) this problem has been fixed in
version 6.2.4.5-0.6.
We recommend that you upgrade your imagemagick packages.


Solution : http://www.debian.org/security/2006/dsa-957
Network Security Threat Level: High

Networks Security ID: 16093

Vulnerability Assessment Copyright: This script is (C) 2007 Michel Arboi

Cables, Connectors

Linksys SE1500 5-Port 10/100Mbps Desktop Switch - (Certified Refurbished)
$25.69
Linksys SE1500 5-Port 10/100Mbps Desktop Switch - (Certified Refurbished) pictureLOT of 10x AGM731F Netgear Compatible SFP SX 1Gb/s Transceivers
$98.92
LOT of 10x AGM731F Netgear Compatible SFP SX 1Gb/s Transceivers pictureCisco WS-C4503-E 3-slot chassi [1xPSU] (QTY: 3)
$190.0
Cisco WS-C4503-E 3-slot chassi [1xPSU] (QTY: 3) pictureCisco Catalyst 2960S-48LPS-L Switch (QTY: 32)
$550.0
Cisco Catalyst 2960S-48LPS-L Switch (QTY: 32) picture


Discussions

No Discussions have been posted on this vulnerability.