Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA932] DSA-932-1 kdegraphics


Vulnerability Assessment Details

[DSA932] DSA-932-1 kdegraphics

Vulnerability Assessment Summary
DSA-932-1 kdegraphics

Detailed Explanation for this Vulnerability Assessment

"infamous41md" and Chris Evans discovered several heap based buffer
overflows in xpdf, the Portable Document Format (PDF) suite, that can
lead to a denial of service by crashing the application or possibly to
the execution of arbitrary code. The same code is present in kpdf
which is part of the kdegraphics package.
The old stable distribution (woody) does not contain kpdf packages.
For the stable distribution (sarge) these problems have been fixed in
version 3.3.2-2sarge3.
For the unstable distribution (sid) these problems have been fixed in
version 3.5.0-3.
We recommend that you upgrade your kpdf package.


Solution : http://www.debian.org/security/2006/dsa-932
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is (C) 2007 Michel Arboi

Cables, Connectors

Lenovo ThinkPad X230 12.5in. Notebook/Laptop - Customized
$175.0
Lenovo ThinkPad X230 12.5in. Notebook/Laptop - Customized pictureLenovo AC Adapter 65W 20V ThinkPad Laptop Charger****
$0.01
Lenovo AC Adapter 65W 20V ThinkPad Laptop Charger**** pictureLenovo Tab A8-50
$50.0
Lenovo Tab A8-50 pictureLenovo ThinkPad Yoga 14 Graphite 14-Inch Black Customized Tablet/Laptop...
$500.0
Lenovo ThinkPad Yoga 14 Graphite 14-Inch Black Customized Tablet/Laptop... picture


Discussions

No Discussions have been posted on this vulnerability.