Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA924] DSA-924-1 nbd


Vulnerability Assessment Details

[DSA924] DSA-924-1 nbd

Vulnerability Assessment Summary
DSA-924-1 nbd

Detailed Explanation for this Vulnerability Assessment

Kurt Fitzner discovered a buffer overflow in nbd, the network block
device client and server that could potentially permit arbitrary code on
the NBD server.
For the old stable distribution (woody) this problem has been fixed in
version 1.2cvs20020320-3.woody.3.
For the stable distribution (sarge) this problem has been fixed in
version 2.7.3-3sarge1.
For the unstable distribution (sid) this problem will be fixed soon.
We recommend that you upgrade your nbd-server package.


Solution : http://www.debian.org/security/2005/dsa-924
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is (C) 2006 Michel Arboi

Cables, Connectors

DELL PowerEdge R710 Server 2x 2.40Ghz E5645 6C 144GB 3x 300GB SSD 5x 600GB SAS
$1533.4
DELL PowerEdge R710 Server 2x 2.40Ghz E5645 6C 144GB 3x 300GB SSD 5x 600GB SAS pictureDell PowerEdge T320 Tower Server | 2.40GHz 6-Core | 24GB RAM | H310
$475.2
Dell PowerEdge T320 Tower Server | 2.40GHz 6-Core | 24GB RAM | H310 pictureDell PowerEdge R610 2x X5570 2.93GHz Quad Core 64GB 6x 146GB 15K SAS PERC 6/i
$755.0
Dell PowerEdge R610 2x X5570 2.93GHz Quad Core 64GB 6x 146GB 15K SAS PERC 6/i pictureDell PowerEdge Server 2.5" Hard Drive Tray Blank Filler - Lot of 10
$20.0
Dell PowerEdge Server 2.5


Discussions

No Discussions have been posted on this vulnerability.