Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA904] DSA-904-1 netpbm-free


Vulnerability Assessment Details

[DSA904] DSA-904-1 netpbm-free

Vulnerability Assessment Summary
DSA-904-1 netpbm-free

Detailed Explanation for this Vulnerability Assessment

Greg Roelofs discovered and fixed several buffer overflows in pnmtopng
which is also included in netpbm, a collection of graphic conversion
utilities, that can lead to the execution of arbitrary code via a
specially crafted PNM file.
For the old stable distribution (woody) these problems have been fixed in
version 9.20-8.5.
For the stable distribution (sarge) these problems have been fixed in
version 10.0-8sarge2.
For the unstable distribution (sid) these problems will be fixed in
version 10.0-11.
We recommend that you upgrade your netpbm package.


Solution : http://www.debian.org/security/2005/dsa-904
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is (C) 2007 Michel Arboi

Cables, Connectors

Vintage Computer PC Corridor 7 Seven Alien Invasion 2 Dos 3.5 disk
$20.0
  Vintage Computer PC  Corridor 7 Seven Alien Invasion 2 Dos 3.5 disk  pictureVintage Double Disk Converter Heavy Metal 3.5 " tool computer DDC-741
$5.0
Vintage Double Disk Converter Heavy Metal 3.5 MacCase 15 in. Premium Leather MacBook Pro Sleeve [ID 799160]
$128.19
MacCase 15 in. Premium Leather MacBook Pro Sleeve [ID 799160] picturePremium Leather Large Shoulder Bag w 13 in. Sleeve [ID 796810]
$389.35
Premium Leather Large Shoulder Bag w 13 in. Sleeve [ID 796810] picture


Discussions

No Discussions have been posted on this vulnerability.