Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA883] DSA-883-1 thttpd


Vulnerability Assessment Details

[DSA883] DSA-883-1 thttpd

Vulnerability Assessment Summary
DSA-883-1 thttpd

Detailed Explanation for this Vulnerability Assessment

Javier Fernández-Sanguino Peña from the Debian Security Audit team
discovered that the syslogtocern script from thttpd, a tiny webserver,
uses a temporary file insecurely, permiting a local attacker to craft a
symlink attack to overwrite arbitrary files.
For the old stable distribution (woody) this problem has been fixed in
version 2.21b-11.3.
For the stable distribution (sarge) this problem has been fixed in
version 2.23beta1-3sarge1.
For the unstable distribution (sid) this problem has been fixed in
version 2.23beta1-4.
We recommend that you upgrade your thttpd package.


Solution : http://www.debian.org/security/2005/dsa-883
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is (C) 2007 Michel Arboi

Cables, Connectors

Cisco Catalyst WS-C3850-24XS Layer 3 Switch
$25000.0
Cisco Catalyst WS-C3850-24XS Layer 3 Switch pictureCisco WS-C2960+24TC-S Catalyst 2960 Plus 24 10/100 + 2 T/SFP LAN Lite Switch NEW
$694.27
Cisco WS-C2960+24TC-S Catalyst 2960 Plus 24 10/100 + 2 T/SFP LAN Lite Switch NEW pictureWS-C3560G-48PS-S 3560 CISCO Gigabit Power PoE Switch
$1273.14
WS-C3560G-48PS-S 3560 CISCO Gigabit Power PoE Switch picture1PCS NetGear ProSafe GSM7352S 48-Ports External Switch
$517.74
1PCS NetGear ProSafe GSM7352S 48-Ports External Switch picture


Discussions

No Discussions have been posted on this vulnerability.