Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA864] DSA-864-1 ruby1.8


Vulnerability Assessment Details

[DSA864] DSA-864-1 ruby1.8

Vulnerability Assessment Summary
DSA-864-1 ruby1.8

Detailed Explanation for this Vulnerability Assessment

Yutaka Oiwa discovered a bug in Ruby, the interpreter for the
object-oriented scripting language, that can cause illegal program
code to bypass the safe level and taint flag protections check and be
executed. The following matrix lists the fixed versions in our
distributions:
We recommend that you upgrade your ruby packages.


Solution : http://www.debian.org/security/2005/dsa-864
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is (C) 2005 Michel Arboi

Cables, Connectors

Dell PowerEdge R720 2x E5-2620 2.0GHz 6 Core 16GB 8x 1TB 7.2K SAS H710
$3025.0
Dell PowerEdge R720 2x E5-2620 2.0GHz 6 Core 16GB 8x 1TB 7.2K SAS H710 pictureNEW Lenovo Yoga 910 13.9" 14" 4K UHD Laptop Core i7-7500U 16GB 1TB PCIe SSD 3lb
$30.88
NEW Lenovo Yoga 910 13.9Barebones PC MM2.62.545 AMD FX 8350 4.0GHz ASUS M5A78L-M LX 8GB DDR3 1TB
$584.0
Barebones PC MM2.62.545 AMD FX 8350 4.0GHz ASUS M5A78L-M LX 8GB DDR3 1TB pictureLaptop Lenovo G50-45/AMD A8/8GB/1TB
$318.66
Laptop Lenovo G50-45/AMD A8/8GB/1TB picture


Discussions

No Discussions have been posted on this vulnerability.