Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA821] DSA-821-1 python2.3


Vulnerability Assessment Details

[DSA821] DSA-821-1 python2.3

Vulnerability Assessment Summary
DSA-821-1 python2.3

Detailed Explanation for this Vulnerability Assessment

An integer overflow with a subsequent buffer overflow has been detected
in PCRE, the Perl Compatible Regular Expressions library, which permits
a possible hacker to execute arbitrary code, and is also present in Python.
Exploiting this vulnerability requires a possible hacker to specify the used
regular expression.
The old stable distribution (woody) does not contain python2.3 packages.
For the stable distribution (sarge) this problem has been fixed in
version 2.3.5-3sarge1.
For the unstable distribution (sid) this problem has been fixed in
version 2.3.5-8.
We recommend that you upgrade your python2.3 packages.


Solution : http://www.debian.org/security/2005/dsa-821
Network Security Threat Level: High

Networks Security ID: 14620

Vulnerability Assessment Copyright: This script is (C) 2007 Michel Arboi

Cables, Connectors

SAMSUNG LTN170X2-L02 17" LCD LAPTOP SCREEN
$29.99
SAMSUNG LTN170X2-L02 17Samsung All-In-One DP700A3B Touchscreen Computer, FOR PARTS/REPAIR NO HDD RAM
$69.99
Samsung All-In-One DP700A3B Touchscreen Computer, FOR PARTS/REPAIR NO HDD RAM picture10 Samsung Galaxy Tabs Book Cover for 8.4" Model (SAMSUNG ORIGINAL)
$70.0
10 Samsung Galaxy Tabs Book Cover for 8.4Samsung MLT-D206L/XAA Black Toner Cartridge SCX-5935
$60.0
Samsung MLT-D206L/XAA Black Toner Cartridge SCX-5935 picture


Discussions

No Discussions have been posted on this vulnerability.