Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA786] DSA-786-1 simpleproxy


Vulnerability Assessment Details

[DSA786] DSA-786-1 simpleproxy

Vulnerability Assessment Summary
DSA-786-1 simpleproxy

Detailed Explanation for this Vulnerability Assessment

Ulf Härnhammar from the Debian Security Audit Project discovered a
format string vulnerability in simpleproxy, a simple TCP proxy, that
can be exploited via replies from remote HTTP proxies.
The old stable distribution (woody) is not affected.
For the stable distribution (sarge) this problem has been fixed in
version 3.2-3sarge1.
For the unstable distribution (sid) this problem has been fixed in
version 3.2-4.
We recommend that you upgrade your simpleproxy package.


Solution : http://www.debian.org/security/2005/dsa-786
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is (C) 2007 Michel Arboi

Cables, Connectors

IBM System x3550 M2 Server Xeon E5530 2.4GHz No HDDs
$90.0
IBM System x3550 M2 Server Xeon E5530 2.4GHz No HDDs pictureBrand New IBM x3850 X6 Server Heatsink 95Y4388 95Y4392 US-SameDayShipping
$99.0
Brand New IBM x3850 X6 Server Heatsink 95Y4388 95Y4392 US-SameDayShipping pictureIBM/Lenovo 40K6589 Cable Management Server Arm for Series X345 40K6590 G32891K
$19.95
IBM/Lenovo 40K6589 Cable Management Server Arm for Series X345 40K6590 G32891K pictureDell JW06 Server PERC 6/IR SAS RAID Controller Card+SAS TO SATA Data line
$19.0
Dell JW06 Server PERC 6/IR SAS RAID Controller Card+SAS TO SATA Data line picture


Discussions

No Discussions have been posted on this vulnerability.