Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA658] DSA-658-1 libdbi-perl


Vulnerability Assessment Details

[DSA658] DSA-658-1 libdbi-perl

Vulnerability Assessment Summary
DSA-658-1 libdbi-perl

Detailed Explanation for this Vulnerability Assessment

Javier Fernández-Sanguino Peña from the Debian Security Audit Project
discovered that the DBI library, the Perl5 database interface, creates
a temporary PID file in an insecure manner. This can be exploited by a
malicious user to overwrite arbitrary files owned by the person
executing the parts of the library.
For the stable distribution (woody) this problem has been fixed in
version 1.21-2woody2.
For the unstable distribution (sid) this problem has been fixed in
version 1.46-6.
We recommend that you upgrade your libdbi-perl package.


Solution : http://www.debian.org/security/2005/dsa-658
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is (C) 2005 Michel Arboi

Cables, Connectors

WARRANTY Lenovo Edge E555 ThinkPad 20DH-002QUS AMD 2.20GHz Windows 10 PRO 4/250
$249.0
WARRANTY Lenovo Edge E555 ThinkPad 20DH-002QUS AMD 2.20GHz Windows 10 PRO 4/250 pictureBRAND NEW LENOVO T410 BETTERY
$12.0
BRAND NEW LENOVO T410 BETTERY pictureLENOVO DCG SERVER OPTIONS 4XB0K12327 240GB LTS GEN 5 SSD SATA 3.5IN
$257.29
LENOVO DCG SERVER OPTIONS 4XB0K12327  240GB LTS GEN 5 SSD SATA 3.5IN pictureIBM Lenovo ThinkPad T420 Core i5 2.5GHz 4GB 500GB Webcam 1600x900 Win 7 Laptop
$165.0
IBM Lenovo ThinkPad T420 Core i5 2.5GHz 4GB 500GB Webcam 1600x900 Win 7 Laptop picture


Discussions

No Discussions have been posted on this vulnerability.