Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA593] DSA-593-1 imagemagick


Vulnerability Assessment Details

[DSA593] DSA-593-1 imagemagick

Vulnerability Assessment Summary
DSA-593-1 imagemagick

Detailed Explanation for this Vulnerability Assessment

A vulnerability has been reported for ImageMagick, a commonly used
image manipulation library. Due to a boundary error within the EXIF
parsing routine, a specially crafted graphic image could lead to the
execution of arbitrary code.
For the stable distribution (woody) this problem has been fixed in
version 5.4.4.5-1woody4.
For the unstable distribution (sid) this problem has been fixed in
version 6.0.6.2-1.5.
We recommend that you upgrade your imagemagick packages.


Solution : http://www.debian.org/security/2004/dsa-593
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is (C) 2005 Michel Arboi

Cables, Connectors

Vintage Macintosh Apple Keyboard M0110 - Perfect Looking - Tested Working / MAC
$50.0
Vintage Macintosh Apple Keyboard M0110 - Perfect Looking - Tested Working / MAC pictureGus & the Cyberbuds ~ Cyberstone Park~ Vintage PC MAC Software
$9.95
Gus & the Cyberbuds ~ Cyberstone Park~ Vintage PC MAC Software  pictureVintage**Michael Santoro**Mac Case**Apple Macbook Pro Case**Leather Messenger
$29.99
Vintage**Michael Santoro**Mac Case**Apple Macbook Pro Case**Leather Messenger pictureApple Wired USB Keyboard M7803 Black Vintage Mac Pro iMac G5
$20.0
Apple Wired USB Keyboard M7803 Black Vintage Mac Pro iMac G5 picture


Discussions

No Discussions have been posted on this vulnerability.