Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA591] DSA-591-1 libgd2


Vulnerability Assessment Details

[DSA591] DSA-591-1 libgd2

Vulnerability Assessment Summary
DSA-591-1 libgd2

Detailed Explanation for this Vulnerability Assessment

"infamous41md" discovered several integer overflows in the PNG image
decoding routines of the GD graphics library. This could lead to the
execution of arbitrary code on the victim's machine.
For the stable distribution (woody) these problems have been fixed in
version 1.8.4-17.woody3 of libgd1 and in version 2.0.1-10woody1 of
libgd2.
For the unstable distribution (sid) these problems will be fixed soon.
We recommend that you upgrade your libgd2 packages.


Solution : http://www.debian.org/security/2004/dsa-591
Network Security Threat Level: High

Networks Security ID: 11523

Vulnerability Assessment Copyright: This script is (C) 2005 Michel Arboi

Cables, Connectors

Promise Technology Pegasus2 R4 Thunderbolt RAID Storage Array w/ 4x 2TB (8TB)
$659.76
Promise Technology Pegasus2 R4 Thunderbolt RAID Storage Array w/ 4x 2TB (8TB) pictureNewerTech 1TB Guardian Maximus mini Quad Interface RAID Drive
$99.99
NewerTech 1TB Guardian Maximus mini Quad Interface RAID Drive pictureLenovo Think Server RAID 510i AnyRAID Adapter Storage Controller 4XB0F28691 ZZ
$211.7
Lenovo Think Server RAID 510i AnyRAID Adapter Storage Controller 4XB0F28691 ZZ pictureLenovo Think Server RAID 720ix AnyRAID Adapter with Expander 4XB0F28694 ZZ
$337.95
Lenovo Think Server RAID 720ix AnyRAID Adapter with Expander 4XB0F28694 ZZ picture


Discussions

No Discussions have been posted on this vulnerability.