Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA589] DSA-589-1 libgd1


Vulnerability Assessment Details

[DSA589] DSA-589-1 libgd1

Vulnerability Assessment Summary
DSA-589-1 libgd1

Detailed Explanation for this Vulnerability Assessment

"infamous41md" discovered several integer overflows in the PNG image
decoding routines of the GD graphics library. This could lead to the
execution of arbitrary code on the victim's machine.
For the stable distribution (woody) these problems have been fixed in
version 1.8.4-17.woody3 of libgd1 and in version 2.0.1-10woody1 of
libgd2.
For the unstable distribution (sid) these problems will be fixed soon.
We recommend that you upgrade your libgd1 packages.


Solution : http://www.debian.org/security/2004/dsa-589
Network Security Threat Level: High

Networks Security ID: 11523

Vulnerability Assessment Copyright: This script is (C) 2005 Michel Arboi

Cables, Connectors

Cisco ASA5520 Adaptive Security Appliance Firewall VPN Plus w/ ASA-SSM-10
$110.0
Cisco ASA5520 Adaptive Security Appliance Firewall VPN Plus w/ ASA-SSM-10 pictureLot of 2 Used Netgear ProSafe VPN Firewalls (Model# FVS318)
$15.0
Lot of 2 Used Netgear ProSafe VPN Firewalls (Model# FVS318) pictureLot of 3 Used Netgear ProSafe VPN Firewalls (Model# FVS318)
$18.0
Lot of 3 Used Netgear ProSafe VPN Firewalls (Model# FVS318) pictureLot of 2 Used Netgear ProSafe VPN Firewalls (Model# FVS318)
$15.0
Lot of 2 Used Netgear ProSafe VPN Firewalls (Model# FVS318) picture


Discussions

No Discussions have been posted on this vulnerability.