Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA552] DSA-552-1 imlib2


Vulnerability Assessment Details

[DSA552] DSA-552-1 imlib2

Vulnerability Assessment Summary
DSA-552-1 imlib2

Detailed Explanation for this Vulnerability Assessment

Marcus Meissner discovered a heap overflow error in imlib2, an imaging
library for X and X11 and the successor of imlib, that may be utilised
by a possible hacker to execute arbitrary code on the victims machine.
For the stable distribution (woody) this problem has been fixed in
version 1.0.5-2woody1.
For the unstable distribution (sid) this problem has been fixed in
version 1.1.0-12.4.
We recommend that you upgrade your imlib2 packages.


Solution : http://www.debian.org/security/2004/dsa-552
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is (C) 2005 Michel Arboi

Cables, Connectors

Dell Poweredge 1950 2x E5310 QC Quad Core 1.60Ghz 4GB #
$699.0
Dell Poweredge 1950 2x E5310 QC Quad Core 1.60Ghz 4GB # pictureDell PowerEdge R720xd 24-Bay - 2x HS - Dual PSU - H710p - Ent. Lic, Rails, Bezel
$1275.0
Dell PowerEdge R720xd 24-Bay - 2x HS - Dual PSU - H710p - Ent. Lic, Rails, Bezel pictureDell PowerEdge R720xd 2x E5-2690 2.9Ghz 8 Core 192GB RAM 12x 300GB 15K SAS H710p
$3475.0
Dell PowerEdge R720xd 2x E5-2690 2.9Ghz 8 Core 192GB RAM 12x 300GB 15K SAS H710p picture32 GB (8x4GB) SERVER RAM PC5300 DDR2 Fully Buffered for DELL and HP ProLiant
$69.0
32 GB (8x4GB) SERVER RAM  PC5300 DDR2 Fully Buffered for DELL and  HP ProLiant picture


Discussions

No Discussions have been posted on this vulnerability.