Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA535] DSA-535-1 squirrelmail


Vulnerability Assessment Details

[DSA535] DSA-535-1 squirrelmail

Vulnerability Assessment Summary
DSA-535-1 squirrelmail

Detailed Explanation for this Vulnerability Assessment

Four vulnerabilities were discovered in squirrelmail:
Multiple cross-site scripting (XSS) vulnerabilities
in SquirrelMail 1.4.2 permit remote attackers to execute arbitrary
script as other users and possibly steal authentication information
via multiple attack vectors, including the mailbox parameter in
compose.php.
Cross-site scripting (XSS) vulnerability in mime.php
for SquirrelMail before 1.4.3 permits remote attackers to insert
arbitrary HTML and script via the content-type mail header, as
demonstrated using read_body.php.
SQL injection vulnerability in SquirrelMail before
1.4.3 RC1 permits remote attackers to execute unauthorized SQL
statements, with unknown impact, probably via abook_database.php.
Multiple cross-site scripting (XSS) vulnerabilities
in Squirrelmail 1.2.10 and earlier permit remote attackers to inject
arbitrary HTML or script via (1) the $mailer variable in
read_body.php, (2) the $senderNames_part variable in
mailbox_display.php, and possibly other vectors including (3) the
$event_title variable or (4) the $event_text variable.
For the current stable distribution (woody), these problems have been
fixed in version 1:1.2.6-1.4.
For the unstable distribution (sid), these problems have been fixed in
2:1.4.3a-0.1 and earlier versions.
We recommend that you update your squirrelmail package.


Solution : http://www.debian.org/security/2004/dsa-535
Network Security Threat Level: High

Networks Security ID: 10246, 10439

Vulnerability Assessment Copyright: This script is (C) 2006 Michel Arboi

Cables, Connectors

Black Hands Free Overhead VOIP Skype Headset With Microphone 3.5mm Audio Speaker
$8.93
Black Hands Free Overhead VOIP Skype Headset With Microphone 3.5mm Audio Speaker pictureVoIP ATA FXS gateway 8FXS VoIP gateway HT-882 VoIP Analog Terminal Adapter
$140.0
VoIP ATA FXS gateway 8FXS VoIP gateway HT-882 VoIP Analog Terminal Adapter pictureLinksys VoIP Gateway Router (voice gateway with router)
$22.5
Linksys VoIP Gateway Router (voice gateway with router) picturePlug n' Play USB 2.0 Stereo Headset Headphone For Laptop PC Games Skype VOIP G13
$16.2
Plug n' Play USB 2.0 Stereo Headset Headphone For Laptop PC Games Skype VOIP G13 picture


Discussions

No Discussions have been posted on this vulnerability.