Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA508] DSA-508-1 xpcd


Vulnerability Assessment Details

[DSA508] DSA-508-1 xpcd

Vulnerability Assessment Summary
DSA-508-1 xpcd

Detailed Explanation for this Vulnerability Assessment

Jaguar discovered a vulnerability in one component of xpcd, a PhotoCD
viewer. xpcd-svga, part of xpcd which uses svgalib to display
graphics on the console, would copy user-supplied data of arbitrary
length into a fixed-size buffer in the pcd_open function.
For the current stable distribution (woody) this problem has been
fixed in version 2.08-8woody2.
For the unstable distribution (sid), this problem will be fixed soon.
We recommend that you update your xpcd package.


Solution : http://www.debian.org/security/2004/dsa-508
Network Security Threat Level: High

Networks Security ID: 10403

Vulnerability Assessment Copyright: This script is (C) 2005 Michel Arboi

Cables, Connectors

Lenovo-Yoga-2-Pro-Laptop-Motherboard-5B20G38212
$120.0
Lenovo-Yoga-2-Pro-Laptop-Motherboard-5B20G38212 pictureNEW Lenovo DCG 00YJ195 Xeon Octa-core E5-2620 v4 2.1GHz Server Processor Upgrade
$749.98
NEW Lenovo DCG 00YJ195 Xeon Octa-core E5-2620 v4 2.1GHz Server Processor Upgrade pictureNEW Lenovo 4X10E52935 ThinkPad OneLink Pro Dock Docking Station TP FD Only
$179.98
NEW Lenovo 4X10E52935 ThinkPad OneLink Pro Dock Docking Station TP FD Only pictureNEW Lenovo DCG 4XC0G88850 ThinkServer RAID 520i PCIe Adapter SAS Controller LTS
$393.98
NEW Lenovo DCG 4XC0G88850 ThinkServer RAID 520i PCIe Adapter SAS Controller LTS picture


Discussions

No Discussions have been posted on this vulnerability.