Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA505] DSA-505-1 cvs


Vulnerability Assessment Details

[DSA505] DSA-505-1 cvs

Vulnerability Assessment Summary
DSA-505-1 cvs

Detailed Explanation for this Vulnerability Assessment

Stefan Esser discovered a heap overflow in the CVS server, which
serves the popular Concurrent Versions System. Malformed "Entry"
Lines in combination with Is-modified and Unchanged can be used to
overflow malloc()ed memory. This was proven to be exploitable.
For the stable distribution (woody) this problem has been fixed in
version 1.11.1p1debian-9woody4.
For the unstable distribution (sid) this problem has been fixed in
version 1.12.5-6.
We recommend that you upgrade your cvs package immediately.


Solution : http://www.debian.org/security/2004/dsa-505
Network Security Threat Level: High

Networks Security ID: 10384

Vulnerability Assessment Copyright: This script is (C) 2005 Michel Arboi

Cables, Connectors

Intel Core i5 2400S 2.5GHz 6MB 5GT/s SR00S LGA 1155 Desktop CPU
$45.99
Intel Core i5 2400S 2.5GHz 6MB 5GT/s SR00S LGA 1155 Desktop CPU  pictureIntel Core i5 2400S 2.5GHz 6MB 5GT/s SR00S LGA 1155 Desktop CPU
$44.99
Intel Core i5 2400S 2.5GHz 6MB 5GT/s SR00S LGA 1155 Desktop CPU pictureIntel SR04W CORE i5-2430M @ 2.4GHz CPU. CP285
$21.0
Intel SR04W CORE i5-2430M @ 2.4GHz CPU.   CP285 pictureIntel Xeon E5-2620 SR0KW 6 Core 2.0GHz LGA 2011 CPU
$13.0
Intel Xeon E5-2620 SR0KW 6 Core 2.0GHz LGA 2011 CPU picture


Discussions

No Discussions have been posted on this vulnerability.