Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA357] DSA-357-1 wu-ftpd


Vulnerability Assessment Details

[DSA357] DSA-357-1 wu-ftpd

Vulnerability Assessment Summary
DSA-357-1 wu-ftpd

Detailed Explanation for this Vulnerability Assessment

iSEC Security Research reports that wu-ftpd contains an off-by-one bug
in the fb_realpath function which could be exploited by a logged-in user
(local or anonymous) to gain root rights. A demonstration exploit is
reportedly available.
For the current stable distribution (woody) this problem has been fixed
in version 2.6.2-3woody1.
For the unstable distribution (sid) an update will be available shortly.
We recommend you upgrade your wu-ftpd package immediately.


Solution : http://www.debian.org/security/2003/dsa-357
Network Security Threat Level: High

Networks Security ID: 8315

Vulnerability Assessment Copyright: This script is (C) 2005 Michel Arboi

Cables, Connectors

IBM Hot Swap Rear Fan Assembly 04N5121 PG1W-012-110-02 for IBM RS6000 Servers
$34.99
IBM Hot Swap Rear Fan Assembly 04N5121 PG1W-012-110-02 for IBM RS6000 Servers pictureIBM 49Y4242: Intel I340-T4 Quad Port Gigabit PCI-E Server Network Adapter Card
$34.95
IBM 49Y4242: Intel I340-T4 Quad Port Gigabit PCI-E Server Network Adapter Card picture39M5446 IBM Blade Center H Chassis Power Supply Cord server
$100.0
39M5446  IBM Blade Center H Chassis Power Supply Cord server pictureIBM Power 265 AIX Unix workstation (9112-265)
$1016.1
IBM Power 265 AIX Unix workstation (9112-265) picture


Discussions

No Discussions have been posted on this vulnerability.