Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA311] DSA-311-1 linux-kernel-2.4.18


Vulnerability Assessment Details

[DSA311] DSA-311-1 linux-kernel-2.4.18

Vulnerability Assessment Summary
DSA-311-1 linux-kernel-2.4.18

Detailed Explanation for this Vulnerability Assessment

A number of vulnerabilities have been discovered in the Linux kernel.
CVE-2002-0429: The iBCS routines in arch/i386/kernel/traps.c for
Linux kernels 2.4.18 and earlier on x86 systems permit local users to
kill arbitrary processes via a binary compatibility interface
(lcall).
CVE-2003-0001: Multiple ethernet Network Interface Card (NIC) device
drivers do not pad frames with null bytes, which permits remote
attackers to obtain information from previous packets or kernel
memory by using malformed packets.
CVE-2003-0127: The kernel module loader permits local users to gain
root rights by using ptrace to attach to a child process that is
spawned by the kernel.
CVE-2003-0244: The route cache implementation in Linux 2.4, and the
Netfilter IP conntrack module, permits remote attackers to cause a
denial of service (CPU consumption) via packets with forged source
addresses that cause a large number of hash table collisions related
to the PREROUTING chain.
CVE-2003-0246: The ioperm system call in Linux kernel 2.4.20 and
earlier does not properly restrict rights, which permits local
users to gain read or write access to certain I/O ports.
CVE-2003-0247: Vulnerability in the TTY layer of the Linux kernel
2.4 permits attackers to cause a denial of service ("kernel oops").
CVE-2003-0248: The mxcsr code in Linux kernel 2.4 permits attackers
to modify CPU state registers via a malformed address.
CVE-2003-0364: The TCP/IP fragment reassembly handling in the Linux
kernel 2.4 permits remote attackers to cause a denial of service (CPU
consumption) via certain packets that cause a large number of hash
table collisions.
This advisory covers only the i386 (Intel IA32) architectures. Other
architectures will be covered by separate advisories.
For the stable distribution (woody) on the i386 architecture, these
problems have been fixed in kernel-source-2.4.18 version 2.4.18-9,
kernel-image-2.4.18-1-i386 version 2.4.18-8, and
kernel-image-2.4.18-i386bf version 2.4.18-5woody1.
For the unstable distribution (sid) these problems are fixed in the
2.4.20 series kernels based on Debian sources.
We recommend that you update your kernel packages.
If you are using the kernel installed by the installation system when
the "bf24" option is selected (for a 2.4.x kernel), you should install
the kernel-image-2.4.18-bf2.4 package. If you installed a different
kernel-image package after installation, you should install the
corresponding 2.4.18-1 kernel. You may use the table below as a
guide.

| If "uname -r" shows: | Install this package:
| 2.4.18-bf2.4 | kernel-image-2.4.18-bf2.4
| 2.4.18-386 | kernel-image-2.4.18-1-386
| 2.4.18-586tsc | kernel-image-2.4.18-1-586tsc
| 2.4.18-686 | kernel-image-2.4.18-1-686
| 2.4.18-686-smp | kernel-image-2.4.18-1-686-smp
| 2.4.18-k6 | kernel-image-2.4.18-1-k6
| 2.4.18-k7 | kernel-image-2.4.18-1-k7


NOTE: that this kernel is not binary compatible with the previous
version. For this reason, the kernel has a different version number
and will not be in
[...]

Solution : http://www.debian.org/security/2003/dsa-311
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is (C) 2005 Michel Arboi

Cables, Connectors

IBM x3650 Server
$350.0
IBM x3650 Server pictureibm x3250 Server
$200.0
ibm x3250 Server pictureIBM 7158-AC1 X3630 M4 LFF 16-Core 1.8GHz E5-2450L 96GB 12x 73GB SAS 15K 9200-8i
$844.99
IBM 7158-AC1 X3630 M4 LFF 16-Core 1.8GHz E5-2450L 96GB 12x 73GB SAS 15K 9200-8i  pictureIBM 7158-AC1 X3630 M4 LFF 16-Core 1.8GHz E5-2450L 96GB 14x 73GB SAS 15K 9200-8i
$859.99
IBM 7158-AC1 X3630 M4 LFF 16-Core 1.8GHz E5-2450L 96GB 14x 73GB SAS 15K 9200-8i  picture


Discussions

No Discussions have been posted on this vulnerability.