Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA204] DSA-204-1 kdelibs


Vulnerability Assessment Details

[DSA204] DSA-204-1 kdelibs

Vulnerability Assessment Summary
DSA-204-1 kdelibs

Detailed Explanation for this Vulnerability Assessment

The KDE team has discovered a vulnerability in the support for various
network protocols via the KIO. The implementation of the rlogin and telnet
protocols permits a carefully crafted URL in an HTML page, HTML email or
other KIO-enabled application to execute arbitrary commands on the
system using the victim's account on the vulnerable machine.
This problem has been fixed by disabling rlogin and telnet in version
2.2.2-13.woody.5 for the current stable distribution (woody). The old
stable distribution (potato) is not affected since it doesn't contain
KDE. A correction for the package in the unstable distribution (sid)
is not yet available.
We recommend that you upgrade your kdelibs3 package immediately.


Solution : http://www.debian.org/security/2002/dsa-204
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is (C) 2005 Michel Arboi

Cables, Connectors

TRENDNET smart switch board 52-port gigabit TEG-2248WS
$149.99
TRENDNET smart switch board 52-port gigabit TEG-2248WS pictureCisco Catalyst 3560G-48TS - switch - managed - 48 ports Cisco Catalyst...
$125.0
Cisco Catalyst 3560G-48TS - switch - managed - 48 ports Cisco Catalyst... pictureEdge-Core ECS4210-28p
$124.0
Edge-Core ECS4210-28p picture


Discussions

No Discussions have been posted on this vulnerability.