Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA1261] DSA-1261-1 postgresql


Vulnerability Assessment Details

[DSA1261] DSA-1261-1 postgresql

Vulnerability Assessment Summary
DSA-1261-1 postgresql

Detailed Explanation for this Vulnerability Assessment

It was discovered that the PostgreSQL database performs insufficient type
checking for SQL function arguments, which might lead to denial of service
or information disclosure.
For the stable distribution (sarge) this problem has been fixed in
version 7.4.7-6sarge4.
For the upcoming stable distribution (etch) this problem has been
fixed in version 8.1.7-1 of the postgresql-8.1 package.
For the unstable distribution (sid) this problem has been fixed in
version 8.1.7-1 of the postgresql-8.1 package.
We recommend that you upgrade your PostgreSQL packages.


Solution : http://www.debian.org/security/2007/dsa-1261
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is (C) 2007 Michel Arboi

Cables, Connectors

Lot Of 7 Dell PowerConnect 6248 - switch - 48 ports
$750.0
Lot Of 7 Dell PowerConnect 6248 - switch - 48 ports pictureMiniView iogear GCS 1802 (2 Port) KVMP SWITCH With USB 2.0 Hub and Audio
$25.0
MiniView iogear GCS 1802  (2 Port) KVMP SWITCH With USB 2.0 Hub and Audio pictureNEW BUFFALO BS-GU2008P 8-Port Desktop Gigabit POE
$50.0
NEW BUFFALO BS-GU2008P 8-Port Desktop Gigabit POE pictureNetgear FS108 v2 Fast Ethernet Switch - 8 Port With Power Supply B
$15.65
Netgear FS108 v2 Fast Ethernet Switch - 8 Port With Power Supply     B picture


Discussions

No Discussions have been posted on this vulnerability.