Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA1240] DSA-1240-1 links2


Vulnerability Assessment Details

[DSA1240] DSA-1240-1 links2

Vulnerability Assessment Summary
DSA-1240-1 links2

Detailed Explanation for this Vulnerability Assessment

Teemu Salmela discovered that the links2 character mode web browser
performs insufficient sanitising of smb:// URIs, which might lead to the
execution of arbitrary shell commands.
For the stable distribution (sarge) this problem has been fixed in
version 2.1pre16-1sarge1.
For the upcoming stable distribution (etch) this problem has been
fixed in version 2.1pre26-1.
For the unstable distribution (sid) this problem has been fixed in
version 2.1pre26-1.
We recommend that you upgrade your links2 package.


Solution : http://www.debian.org/security/2006/dsa-1240
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is (C) 2007 Michel Arboi

Cables, Connectors

Supermicro Server Micro 6027TR-DTRF 2 X E5-2630L 16GB 1x HDD Tray Per Node RAILS
$500.0
Supermicro Server Micro 6027TR-DTRF 2 X E5-2630L 16GB 1x HDD Tray Per Node RAILS pictureSuper Micro Computer X9SCA LGA 1155 Intel Server Motherboard
$123.89
Super Micro Computer X9SCA LGA 1155 Intel Server Motherboard pictureHP PROLIANT MICROSERVER G8 E3-1220LV2 2.3GHZ 4GB 1TB
$729.0
HP PROLIANT MICROSERVER G8 E3-1220LV2 2.3GHZ 4GB 1TB pictureHP PROLIANT MICROSERVER G8 E3-1220LV2 2.3GHZ 16GB 2 X 800GB SSD
$2209.0
HP PROLIANT MICROSERVER G8 E3-1220LV2 2.3GHZ 16GB 2 X 800GB SSD picture


Discussions

No Discussions have been posted on this vulnerability.