Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA1235] DSA-1235-1 ruby1.8


Vulnerability Assessment Details

[DSA1235] DSA-1235-1 ruby1.8

Vulnerability Assessment Summary
DSA-1235-1 ruby1.8

Detailed Explanation for this Vulnerability Assessment

A denial of service vulnerability has been discovered in the CGI library
included with Ruby, the interpreted scripting language for quick and easy
object-oriented programming.
For the stable distribution (sarge), this problem has been fixed in version
1.8.2-7sarge5.
We recommend that you upgrade your ruby1.8 package.


Solution : http://www.debian.org/security/2006/dsa-1235
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is (C) 2006 Michel Arboi

Cables, Connectors

Lot of 2 IBM Astec AA23260 74P4410 Server Power Supply
$29.95
Lot of 2  IBM Astec AA23260 74P4410 Server Power Supply pictureIBM FLEX SYSTEM X440 7917 FOUR E5-4603 2.0GHZ 64GB 900GB 10K SAS
$3659.0
IBM FLEX SYSTEM X440 7917 FOUR E5-4603 2.0GHZ 64GB 900GB 10K SAS pictureIBM DX360 M3 SERVER X5570 2.93GHZ 8GB 500GB SAS NO GPU
$969.0
IBM DX360 M3 SERVER X5570 2.93GHZ 8GB 500GB SAS NO GPU pictureIBM SYSTEM X3550 M3 SERVER E5640 2.66GHZ 12GB 2 X 1TB SAS
$959.0
IBM SYSTEM X3550 M3 SERVER E5640 2.66GHZ 12GB 2 X 1TB SAS picture


Discussions

No Discussions have been posted on this vulnerability.