Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA1220] DSA-1220-1 pstotext


Vulnerability Assessment Details

[DSA1220] DSA-1220-1 pstotext

Vulnerability Assessment Summary
DSA-1220-1 pstotext

Detailed Explanation for this Vulnerability Assessment

Brian May discovered that pstotext, a utility to extract plain text from
Postscript and PDF files, performs insufficient quoting of file names,
which permits execution of arbitrary shell commands.
For the stable distribution (sarge) this problem has been fixed in
version 1.9-1sarge2. The build for the mipsel architecture is not yet
available due to technical problems with the build host.
For the upcoming stable distribution (etch) this problem has been
fixed in version 1.9-4.
For the unstable distribution (sid) this problem has been fixed in
version 1.9-4.
We recommend that you upgrade your pstotext package.


Solution : http://www.debian.org/security/2006/dsa-1220
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is (C) 2007 Michel Arboi

Cables, Connectors

Juniper Networks JA1500 Junos Space SPC1500-A-BSE
$4695.0
Juniper Networks JA1500 Junos Space  SPC1500-A-BSE pictureJUNIPER EX8216- REDUND-AC-TAA
$450.0
JUNIPER EX8216- REDUND-AC-TAA pictureJuniper MX5-T-AC Router, Dual AC PWR, MIC-3D-20GE-SFP
$4795.0
Juniper MX5-T-AC Router, Dual AC PWR, MIC-3D-20GE-SFP pictureONE USED Juniper EX-UM-4X4SFP 4-port 10-Gigabit Ethernet SFP+ uplink module 
$206.18
ONE USED Juniper EX-UM-4X4SFP 4-port 10-Gigabit Ethernet SFP+ uplink module  picture


Discussions

No Discussions have been posted on this vulnerability.