Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA1215] DSA-1215-1 xine-lib


Vulnerability Assessment Details

[DSA1215] DSA-1215-1 xine-lib

Vulnerability Assessment Summary
DSA-1215-1 xine-lib

Detailed Explanation for this Vulnerability Assessment

Several remote vulnerabilities have been discovered in the Xine multimedia
library, which may lead to the execution of arbitrary code. The Common
Vulnerabilities and Exposures project identifies the following problems:
The XFocus Security Team discovered that insufficient validation of
AVI headers may lead to the execution of arbitrary code.
Michael Niedermayer discovered that a buffer overflow in the 4XM
codec may lead to the execution of arbitrary code.
For the stable distribution (sarge) these problems have been fixed in
version 1.0.1-1sarge4.
For the upcoming stable distribution (etch) these problems have been
fixed in version 1.1.2-1.
For the unstable distribution (sid) these problems have been fixed in
version 1.1.2-1.
We recommend that you upgrade your xine-lib packages.


Solution : http://www.debian.org/security/2006/dsa-1215
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is (C) 2007 Michel Arboi

Cables, Connectors

Dell Precision T3500 Workstation, BOOTS Xeon E5430 @ 2.66GHz 4GB RAM 320GB HD
$79.99
Dell Precision T3500 Workstation, BOOTS Xeon E5430 @ 2.66GHz 4GB RAM 320GB HD picture32GB (8x 4GB) Kingston PC3-10600R DDR3-1333 ECC Reg Server RAM KVR1333D3D4R9S/4G
$49.99
32GB (8x 4GB) Kingston PC3-10600R DDR3-1333 ECC Reg Server RAM KVR1333D3D4R9S/4G pictureDell Precision 390 WS BOOTS Core 2 Duo E4400@2.00GHz 2GB RAM 320GB HD NO OS
$19.99
Dell Precision 390 WS BOOTS Core 2 Duo E4400@2.00GHz 2GB RAM 320GB HD NO OS pictureHP DL380 G6 2x Quad-Core Xeon 2.93GHz / 72GB RAM / 8x 146Gb SAS / VMware Ready
$469.0
HP DL380 G6 2x Quad-Core Xeon 2.93GHz / 72GB RAM / 8x 146Gb SAS / VMware Ready picture


Discussions

No Discussions have been posted on this vulnerability.