Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA1207] DSA-1207-2 phpmyadmin


Vulnerability Assessment Details

[DSA1207] DSA-1207-2 phpmyadmin

Vulnerability Assessment Summary
DSA-1207-2 phpmyadmin

Detailed Explanation for this Vulnerability Assessment

The phpmyadmin update in DSA 1207 introduced a regression. This update
corrects this flaw. For completeness, please find below the original
advisory text:
Several remote vulnerabilities have been discovered in phpMyAdmin, a
program to administrate MySQL over the web. The Common Vulnerabilities
and Exposures project identifies the following problems:
CRLF injection vulnerability permits remote attackers to conduct
HTTP response splitting attacks.
Multiple cross-site scripting (XSS) vulnerabilities permit remote
attackers to inject arbitrary web script or HTML via the (1) HTTP_HOST
variable and (2) various scripts in the libraries directory that
handle header generation.
Multiple cross-site scripting (XSS) vulnerabilities permit remote
attackers to inject arbitrary web script or HTML via scripts in the
themes directory.
A cross-site scripting (XSS) vulnerability permits remote attackers
to inject arbitrary web script or HTML via the db parameter of
footer.inc.php.
A remote attacker could overwrite internal variables through the
_FILES global variable.
For the stable distribution (sarge) these problems have been fixed in
version 2.6.2-3sarge3.
For the upcoming stable release (etch) and unstable distribution (sid)
these problems have been fixed in version 2.9.0.3-1.
We recommend that you upgrade your phpmyadmin package.


Solution : http://www.debian.org/security/2006/dsa-1207
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is (C) 2006 Michel Arboi

Cables, Connectors

Adaptec AAR-2420SA 4-Port PCI-X SATA Raid Controller Card *NEW*
$45.99
Adaptec AAR-2420SA 4-Port PCI-X SATA Raid Controller Card *NEW* pictureNew LSI LSI00213 9750-8i 8-port PCI-E SAS RAID Controller Card
$159.99
New LSI LSI00213 9750-8i 8-port PCI-E SAS RAID Controller Card pictureDell Perc J4588 4SC PCI-X PERC4/SC Ultra 320 SCSI Raid Controller Card w/ cable
$37.36
Dell Perc J4588 4SC PCI-X PERC4/SC Ultra 320 SCSI Raid Controller Card w/ cable pictureUSB 2.0 Cable Cord Lead for G-Technology G-RAID 6TB 0G01975 GR4-6000 Hard Drive
$4.99
USB 2.0 Cable Cord Lead for G-Technology G-RAID 6TB 0G01975 GR4-6000 Hard Drive picture


Discussions

No Discussions have been posted on this vulnerability.