Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA1150] DSA-1150-1 shadow


Vulnerability Assessment Details

[DSA1150] DSA-1150-1 shadow

Vulnerability Assessment Summary
DSA-1150-1 shadow

Detailed Explanation for this Vulnerability Assessment

A bug has been discovered in several packages that execute the
setuid() system call without checking for success when trying to drop
rights, which may fail with some PAM configurations.
For the stable distribution (sarge) this problem has been fixed in
version 4.0.3-31sarge8.
For the unstable distribution (sid) this problem has been fixed in
version 4.0.17-2.
We recommend that you upgrade your passwd package.


Solution : http://www.debian.org/security/2006/dsa-1150
Network Security Threat Level: High

Networks Security ID: 18850

Vulnerability Assessment Copyright: This script is (C) 2007 Michel Arboi

Cables, Connectors

Dell PowerEdge R710 2x X5570 2.93GHz Quad Core 128GB 8x 300GB 10K SAS PERC 6/i
$962.0
Dell PowerEdge R710 2x X5570 2.93GHz Quad Core 128GB 8x 300GB 10K SAS PERC 6/i pictureDell PowerEdge R720xd 2x E5-2630 v2 2.6GHz 6 Core 16GB 12x 2TB 7.2K SAS H710P
$4210.0
Dell PowerEdge R720xd 2x E5-2630 v2 2.6GHz 6 Core 16GB 12x 2TB 7.2K SAS H710P pictureDell PowerEdge R710 2x L5640 2.26GHz 6 Core 48GB 8x 256GB SATA SSD PERC 6/i
$1135.0
Dell PowerEdge R710 2x L5640 2.26GHz 6 Core 48GB 8x 256GB SATA SSD PERC 6/i pictureDell PowerEdge R720xd 2x E5-2630 v2 2.6GHz 6 Core 384GB 12x 4TB 7.2K SAS H710P
$6040.0
Dell PowerEdge R720xd 2x E5-2630 v2 2.6GHz 6 Core 384GB 12x 4TB 7.2K SAS H710P picture


Discussions

No Discussions have been posted on this vulnerability.