Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA1073] DSA-1073-1 mysql-dfsg-4.1


Vulnerability Assessment Details

[DSA1073] DSA-1073-1 mysql-dfsg-4.1

Vulnerability Assessment Summary
DSA-1073-1 mysql-dfsg-4.1

Detailed Explanation for this Vulnerability Assessment

Several vulnerabilities have been discovered in MySQL, a popular SQL
database. The Common Vulnerabilities and Exposures Project identifies
the following problems:
Improper handling of SQL queries containing the NULL character
permits local users to bypass logging mechanisms.
Usernames without a trailing null byte permit remote attackers to
read portions of memory.
A request with an incorrect packet length permits remote attackers
to obtain sensitive information.
Specially crafted request packets with invalid length values permit
the execution of arbitrary code.
The following vulnerability matrix shows which version of MySQL in
which distribution has this problem fixed:
We recommend that you upgrade your mysql packages.


Solution : http://www.debian.org/security/2006/dsa-1073
Network Security Threat Level: High

Networks Security ID: 16850, 17780

Vulnerability Assessment Copyright: This script is (C) 2006 Michel Arboi

Cables, Connectors

Dell PowerEdge M610 Blade Server Dual E5506 QC 2.13GHz 24GB 2x 400GB SAS SSD
$800.0
Dell PowerEdge M610 Blade Server Dual E5506 QC 2.13GHz 24GB 2x 400GB SAS SSD pictureHP ProLiant BL460c G8 Blade Server Dual E5-2620 6C 2.0GHz 16GB 2x 72GB 15K SAS
$404.0
HP ProLiant BL460c G8 Blade Server Dual E5-2620 6C 2.0GHz 16GB 2x 72GB 15K SAS pictureHP Renew ML350 G9 Tower Single E5-2623 v3 4-Core 3.0GHz 192GB 4x 600GB 15K SAS
$5782.0
HP Renew ML350 G9 Tower Single E5-2623 v3 4-Core 3.0GHz 192GB 4x 600GB 15K SAS pictureHP ProLiant BL460c G8 Blade Server Dual E5-2670 8C 2.6GHz 32GB 2x 600GB 15K SAS
$1251.0
HP ProLiant BL460c G8 Blade Server Dual E5-2670 8C 2.6GHz 32GB 2x 600GB 15K SAS picture


Discussions

No Discussions have been posted on this vulnerability.