Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA1001] DSA-1001-1 crossfire


Vulnerability Assessment Details

[DSA1001] DSA-1001-1 crossfire

Vulnerability Assessment Summary
DSA-1001-1 crossfire

Detailed Explanation for this Vulnerability Assessment

It was discovered that Crossfire, a multiplayer adventure game, performs
insufficient bounds checking on network packets when run in "oldsocketmode",
which may possibly lead to the execution of arbitrary code.
For the old stable distribution (woody) this problem has been fixed in
version 1.1.0-1woody1.
For the stable distribution (sarge) this problem has been fixed in
version 1.6.0.dfsg.1-4sarge1.
For the unstable distribution (sid) this problem has been fixed in
version 1.9.0-1.
We recommend that you upgrade your crossfire packages.


Solution : http://www.debian.org/security/2006/dsa-1001
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is (C) 2007 Michel Arboi

Cables, Connectors

IBM HS20 Server Blade Gehaeuase / Chassis + Motherboard - 8843 5g
$49.51
IBM HS20 Server Blade Gehaeuase / Chassis + Motherboard - 8843 5g pictureServer RAM 64GB 8x 8GB PC2-5300F FB-DIMM Fully Buffered Memory FIT Dell HP IBM
$73.95
Server RAM 64GB 8x 8GB PC2-5300F FB-DIMM Fully Buffered Memory FIT Dell HP IBM pictureIBM Intel I340-T2 Dual Port Standard Bracket PCI Express 2.0 x4 Server Adapter 4
$27.21
IBM Intel I340-T2 Dual Port Standard Bracket PCI Express 2.0 x4 Server Adapter 4 pictureIBM System X3650 7979-AC1
$275.0
IBM System X3650 7979-AC1 picture


Discussions

No Discussions have been posted on this vulnerability.