Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA044] DSA-044-1 mailx


Vulnerability Assessment Details

[DSA044] DSA-044-1 mailx

Vulnerability Assessment Summary
DSA-044-1 mailx

Detailed Explanation for this Vulnerability Assessment
The mail program (a simple tool to read and send
email) as distributed with Debian GNU/Linux 2.2 has a buffer overflow
in the input parsing code. Since mail is installed setgid mail by
default this permited local users to use it to gain access to mail
group.

Since the mail code was never written to be secure fixing it
properly would mean a large rewrite. Instead of doing this we decided
to no longer install it setgid. This means that it can no longer lock
your mailbox properly on systems for which you need group mail to
write to the mailspool, but it will still work for sending email.

This has been fixed in mailx version 8.1.1-10.1.5. If you have
suidmanager installed you can also make this manually with the
following command:
suidregister /usr/bin/mail root root 0755



Solution : http://www.debian.org/security/2001/dsa-044
Network Security Threat Level: High

Networks Security ID: 2457

Vulnerability Assessment Copyright: This script is (C) 2005 Michel Arboi

Cables, Connectors

DELL POWEREDGE R720 8B 2.5 SERVER TWO E5-2667 2.90GHZ 64GB 6 X 300GB 15K SAS H71
$2339.0
DELL POWEREDGE R720 8B 2.5 SERVER TWO E5-2667 2.90GHZ 64GB 6 X 300GB 15K SAS H71 pictureDELL POWEREDGE R720 8B 2.5 SERVER TWO E5-2695V2 2.40GHZ 32GB 3 X 480GB SSD H310
$3149.0
DELL POWEREDGE R720 8B 2.5 SERVER TWO E5-2695V2 2.40GHZ 32GB 3 X 480GB SSD H310 pictureDELL POWEREDGE C6300 4 NODE C6320 8 X E5-2630V4 2.2GHZ 1024GB 20 X 1.6TB SSD
$24689.0
DELL POWEREDGE C6300 4 NODE C6320 8 X E5-2630V4 2.2GHZ 1024GB 20 X 1.6TB SSD pictureDELL POWEREDGE R630 10 BAY TWO E5-2609V4 1.7GHZ 512GB 8 X 600GB 15K 12G H730
$8269.0
DELL POWEREDGE R630 10 BAY TWO E5-2609V4 1.7GHZ 512GB 8 X 600GB 15K 12G H730 picture


Discussions

No Discussions have been posted on this vulnerability.