Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Databases >> DB2 < 8.1 Fixpack 12


Vulnerability Assessment Details

DB2 < 8.1 Fixpack 12

Vulnerability Assessment Summary
Checks DB2 signature

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote database server is affected by a denial of service issue.

Description :

According to its version, the installation of DB2 on the remote host
may crash when it attempts to process a specially-crafted CONNECT or
ATTACH request sent during the initial handshake process. An
unauthenticated remote attacker can leverage this issue to overflow a
buffer and crash the database instance, thereby denying service to
legitimate users.

See also :

http://archives.neohapsis.com/archives/bugtraq/2006-09/0060.html
http://www-1.ibm.com/support/docview.wss?uid=swg24012305

Solution :

Apply DB2 UDB Version 8.1 FixPak 12 or later.

Network Security Threat Level:

Low / CVSS Base Score : 2.3
(AV:R/AC:L/Au:NR/C:N/I:N/A:P/B:N)

Networks Security ID: 18428

Vulnerability Assessment Copyright: This script is Copyright (C) 2006 Tenable Network Security

Cables, Connectors

Samsung 830 Series MZ-7PC128D 128GB MLC SATA III (6.0Gbps) 2.5" Internal SSD...
$39.99
Samsung 830 Series MZ-7PC128D 128GB MLC SATA III (6.0Gbps) 2.5DATA LOCKER MXKB1B002T5001-B H300 BASIC 2.5 EHDD USB3 2TB
$229.97
DATA LOCKER MXKB1B002T5001-B H300 BASIC 2.5 EHDD USB3 2TB pictureDell 2.5" 100GB 3Gb/s MLC SATA SSD (DYW42)
$55.0
Dell 2.5KingSpec P120 SATA III 3.0 2.5" 120GB MLC Digital SSD Solid State Drive T9N4
$69.78
KingSpec P120 SATA III 3.0 2.5


Discussions

No Discussions have been posted on this vulnerability.