Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gain a shell remotely >> Cyrus IMAPD Multiple Remote Vulnerabilities


Vulnerability Assessment Details

Cyrus IMAPD Multiple Remote Vulnerabilities

Vulnerability Assessment Summary
Checks for a Cyrus IMAPD version

Detailed Explanation for this Vulnerability Assessment

According to its banner, the remote Cyrus IMAPD server is vulnerable to a
remote buffer pre-authentication overflow as well as three post-authentication
overflows.

A possible hacker with or without a valid login could exploit those, and would
be able to execute arbitrary commands as the owner of the Cyrus process.

Solution : Upgrade to Cyrus IMAPD 2.2.10 or newer.
Network Security Threat Level: High

Networks Security ID: 11729, 11738

Vulnerability Assessment Copyright: This script is Copyright (C) 2004-2007 Tenable Network Security

Cables, Connectors

Dell PowerEdge 2850 (PE2850) Server - 2x Xeon 3.0GHz CPU, 4GB DDR2, 2x36GB
$43.0
Dell PowerEdge 2850 (PE2850) Server - 2x Xeon 3.0GHz CPU, 4GB DDR2, 2x36GB pictureDell PowerEdge 2850 (PE2850) Server - 2x Xeon 2.8GHz CPU, 4GB DDR2, 2x36GB
$43.0
Dell PowerEdge 2850 (PE2850) Server - 2x Xeon 2.8GHz CPU, 4GB DDR2, 2x36GB pictureDell G176J KG7NR Hot Swap 2.5" SAS SATA Sled for 11 & 12th Gen Servers
$9.0
Dell G176J KG7NR Hot Swap 2.5Intel Xeon E3-1220V5 3.00GHZ Server Processor Dell
$25.0
Intel Xeon E3-1220V5 3.00GHZ Server Processor Dell picture


Discussions

No Discussions have been posted on this vulnerability.