Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Web Servers >> Cross-Site Scripting in Cherokee Error Pages


Vulnerability Assessment Details

Cross-Site Scripting in Cherokee Error Pages

Vulnerability Assessment Summary
Checks for the version of Cherokee

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server is vulnerable to a cross-site scripting issue.

Description :

The remote host is running Cherokee - a fast and tiny web server.

Due to a lack of sanitization from the user input,
The remote version of this software is vulnerable to cross-site
scripting attacks due to lack of sanitization in returned error pages.

Solution :

Upgrade to Cherokee 0.4.8 or newer.

Network Security Threat Level:

Network Security Threat Level:

Low / CVSS Base Score : 3
(AV:R/AC:H/Au:NR/C:P/A:N/I:N/B:C)

Networks Security ID: 9496

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 David Maciejak

Cables, Connectors

Cisco 2-WIC Network Module, NM-2W
$10.0
Cisco 2-WIC Network Module, NM-2W pictureCisco VWIC2-2MFT-T1/E1 2-port Multiflex Trunk Voice/WAN Interface Card
$6.5
Cisco VWIC2-2MFT-T1/E1 2-port Multiflex Trunk Voice/WAN Interface Card  pictureCisco Linksys E1200 V1 300 Mbps 4-Port Wireless N Router
$6.99
Cisco Linksys E1200 V1 300 Mbps 4-Port Wireless N Router pictureCisco VIC2-2E/M Voice Module interface card
$5.0
Cisco VIC2-2E/M Voice Module interface card picture


Discussions

No Discussions have been posted on this vulnerability.